summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-08-04 08:31:43 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-04 08:46:31 +0100
commit270c3a0b6e400e1e9693a719a1204b8d793fc768 (patch)
tree61b592d54537444ea954ca9f4ee2074c8e5c18e0 /dev-haskell/only
parentdev-haskell/vector-instances: bump up to 3.4 (diff)
downloadgentoo-270c3a0b6e400e1e9693a719a1204b8d793fc768.tar.gz
gentoo-270c3a0b6e400e1e9693a719a1204b8d793fc768.tar.bz2
gentoo-270c3a0b6e400e1e9693a719a1204b8d793fc768.zip
dev-haskell/only: new package, a depend of cassava-0.5
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/only')
-rw-r--r--dev-haskell/only/Manifest1
-rw-r--r--dev-haskell/only/metadata.xml19
-rw-r--r--dev-haskell/only/only-0.1.ebuild29
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-haskell/only/Manifest b/dev-haskell/only/Manifest
new file mode 100644
index 000000000000..31b50286c757
--- /dev/null
+++ b/dev-haskell/only/Manifest
@@ -0,0 +1 @@
+DIST Only-0.1.tar.gz 1960 BLAKE2B b57f48e58287c43395383e355ba9b2d42df4c8b65edbc268e7203853083524dc88540d63a052968b9776dc94064006241188b23e840e1e36872389f9e463d1ff SHA512 6b64178a433079449b6840b03345e70f2c5c03e322184a60d3ff2f4d0ae48be87042ff32dc1cabe1911b6c43f7162090ee067aa582c6d5ab56610ca4897a33de
diff --git a/dev-haskell/only/metadata.xml b/dev-haskell/only/metadata.xml
new file mode 100644
index 000000000000..180274c79810
--- /dev/null
+++ b/dev-haskell/only/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ This package provides a canonical anonymous 1-tuple type missing
+ from Haskell for attaching typeclass instances.
+
+ NOTE: There is also the &lt;/package/OneTuple OneTuple package&gt; which
+ by using a boxed @data@-type provides a 1-tuple type which has
+ laziness properties which are more faithful to the ones of Haskell&#39;s
+ native tuples; whereas the primary purpose of &#39;Only&#39; is to
+ provide the traditionally so named type-wrapper for attaching typeclass
+ instances.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/only/only-0.1.ebuild b/dev-haskell/only/only-0.1.ebuild
new file mode 100644
index 000000000000..f83748215b38
--- /dev/null
+++ b/dev-haskell/only/only-0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.5.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="Only"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="The 1-tuple type or single-value \"collection\""
+HOMEPAGE="http://hackage.haskell.org/package/Only"
+SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"
+
+S="${WORKDIR}/${MY_P}"