summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-05-28 13:55:18 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2017-05-28 18:53:01 +0100
commit678edbfdb8164d64bf5384c00e8d650026988075 (patch)
treeda1e581741cd4157ca8668b871c45240c892cb13 /dev-haskell/path-io/path-io-1.2.2.ebuild
parentdev-haskell/path: new package, a depend of dev-haskell/stack (diff)
downloadgentoo-678edbfdb8164d64bf5384c00e8d650026988075.tar.gz
gentoo-678edbfdb8164d64bf5384c00e8d650026988075.tar.bz2
gentoo-678edbfdb8164d64bf5384c00e8d650026988075.zip
dev-haskell/path-io: new package, a depend of dev-haskell/stack
Interface to 'directory' package for users of 'path' Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-haskell/path-io/path-io-1.2.2.ebuild')
-rw-r--r--dev-haskell/path-io/path-io-1.2.2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-haskell/path-io/path-io-1.2.2.ebuild b/dev-haskell/path-io/path-io-1.2.2.ebuild
new file mode 100644
index 000000000000..54a64dff47ee
--- /dev/null
+++ b/dev-haskell/path-io/path-io-1.2.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+#hackport: flags: -dev
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Interface to 'directory' package for users of 'path'"
+HOMEPAGE="https://github.com/mrkkrp/path-io"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/exceptions-0.8:=[profile?] <dev-haskell/exceptions-0.9:=[profile?]
+ >=dev-haskell/path-0.5:=[profile?] <dev-haskell/path-0.6:=[profile?]
+ >=dev-haskell/temporary-1.1:=[profile?] <dev-haskell/temporary-1.3:=[profile?]
+ dev-haskell/unix-compat:=[profile?]
+ >=dev-lang/ghc-7.10.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.22.2.0
+ test? ( >=dev-haskell/hspec-2.0 <dev-haskell/hspec-3.0 )
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'time >= 1.4 && < 1.7' 'time >= 1.4'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-dev
+}