summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:09:49 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:10:09 +0100
commitab0fb75161f13098440dbfb51a03e3a8d20a606b (patch)
treeb025a17f677291ce09afce9d3d0fe7c5f5755530 /dev-haskell/strict
parentdev-haskell/streaming-commons: add 0.2.2.5 (diff)
downloadgentoo-ab0fb75161f13098440dbfb51a03e3a8d20a606b.tar.gz
gentoo-ab0fb75161f13098440dbfb51a03e3a8d20a606b.tar.bz2
gentoo-ab0fb75161f13098440dbfb51a03e3a8d20a606b.zip
dev-haskell/strict: add 0.5
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/strict')
-rw-r--r--dev-haskell/strict/Manifest1
-rw-r--r--dev-haskell/strict/metadata.xml9
-rw-r--r--dev-haskell/strict/strict-0.5.ebuild37
3 files changed, 42 insertions, 5 deletions
diff --git a/dev-haskell/strict/Manifest b/dev-haskell/strict/Manifest
index 44eea7fb4677..f016b51ca97d 100644
--- a/dev-haskell/strict/Manifest
+++ b/dev-haskell/strict/Manifest
@@ -1,2 +1,3 @@
DIST strict-0.4.0.1.cabal 4187 BLAKE2B 23e7e19b4688a29ee88ee126b7b8d6a7b0176e49bb1ede058690c5ede987f414461a9335a6d5f2f82fc3db46e7c2a62c1773fa6933edd52ed5f09352a2744357 SHA512 f9c98f54d281905ba6f35df31344a4d210a091def005f076f8f613397dc2fb662199f85159a8b513ff1cb28fcc2ccce31449cb51c3cff476232bb43642587621
DIST strict-0.4.0.1.tar.gz 12488 BLAKE2B f652ffa4778d2ed50917730848d469f4a6a3ed2ba0973ccc929891c59b7edecf6492cce807eb5bbc3188f4d21799193e43f3fb34b6230f4da1860d31315b153f SHA512 e0c37396fa507ad4d03e46ce4a02ec5bacbd7add75ca551433671871d3e7dde0eb0c620182904d1bdeb7b80e1b311a70f36030cbeae63d8776059150fef30235
+DIST strict-0.5.tar.gz 12564 BLAKE2B 66cca7f7abaa8262602b602e11ebbeb3b14bd4b2608596c9a01a47a1bf2b6dd7d6bb99f4d1b7892f24db6c4407137b3f1aa0825a5bd1b1e6180ede0090dfe212 SHA512 dba8bb370aaea6107d9ea5ff8bd69a84212eaf0f6440189906bf6d3581282b88ae56142958ab041d9ecd06efee7c51dde9d6bafa89b95e666bf1d48d1249c3ed
diff --git a/dev-haskell/strict/metadata.xml b/dev-haskell/strict/metadata.xml
index b94985c6c9d9..3227376340a4 100644
--- a/dev-haskell/strict/metadata.xml
+++ b/dev-haskell/strict/metadata.xml
@@ -5,9 +5,8 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- This package provides strict versions of some standard Haskell data
- types (pairs, Maybe and Either). It also contains strict IO
- operations.
- </longdescription>
+ <upstream>
+ <remote-id type="hackage">strict</remote-id>
+ <remote-id type="github">haskell-strict/strict</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-haskell/strict/strict-0.5.ebuild b/dev-haskell/strict/strict-0.5.ebuild
new file mode 100644
index 000000000000..eebc629b95ad
--- /dev/null
+++ b/dev-haskell/strict/strict-0.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.2.1.9999
+#hackport: flags: +assoc
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Strict data types and String IO"
+HOMEPAGE="https://github.com/haskell-strict/strict"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-haskell/assoc-1.1:=[profile?] <dev-haskell/assoc-1.2:=[profile?]
+ >=dev-haskell/hashable-1.2.7.0:=[profile?] <dev-haskell/hashable-1.5:=[profile?]
+ >=dev-haskell/these-1.2:=[profile?] <dev-haskell/these-1.3:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+ || (
+ ( >=dev-haskell/text-1.2.3.0 <dev-haskell/text-1.3 )
+ ( >=dev-haskell/text-2.0 <dev-haskell/text-2.1 )
+ )
+ dev-haskell/text:=[profile?]
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=assoc
+}