summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-07-29 11:22:48 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-01 08:59:45 +0100
commitc16a11f280f46525a660397cf23b43dbdc38284c (patch)
tree14eeb60a2de69aecd1029dbae2ece8801a42ba1e /dev-haskell/type-equality
parentdev-haskell/transformers-compat: bump up to 0.6.5 (diff)
downloadgentoo-c16a11f280f46525a660397cf23b43dbdc38284c.tar.gz
gentoo-c16a11f280f46525a660397cf23b43dbdc38284c.tar.bz2
gentoo-c16a11f280f46525a660397cf23b43dbdc38284c.zip
dev-haskell/type-equality: add package
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/type-equality')
-rw-r--r--dev-haskell/type-equality/Manifest1
-rw-r--r--dev-haskell/type-equality/metadata.xml18
-rw-r--r--dev-haskell/type-equality/type-equality-1.ebuild31
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-haskell/type-equality/Manifest b/dev-haskell/type-equality/Manifest
new file mode 100644
index 000000000000..8b377906366d
--- /dev/null
+++ b/dev-haskell/type-equality/Manifest
@@ -0,0 +1 @@
+DIST type-equality-1.tar.gz 4525 BLAKE2B c93061cbf7ad6a02586770dbbbb8c4e47fdee48240b85cb8fc69f78ee8cd05c493585cc14129969814042d3cde2cd4e9468af86e61cfef486b4c3d424b5f413d SHA512 633675251719afa59c311ae82d18476d6e000fbbdc553a29da598da38a29cf73fffcbcd4b23a70dd397f10734ba6617633390874eea8a563a1e258654a9fe7d8
diff --git a/dev-haskell/type-equality/metadata.xml b/dev-haskell/type-equality/metadata.xml
new file mode 100644
index 000000000000..5cf2771db560
--- /dev/null
+++ b/dev-haskell/type-equality/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+ In the presence of GADTs, sometimes a proof is
+ needed that two types are equal. This package
+ contains an equality type for this purpose, plus its
+ properties (reflexive, symmetric, transitive) and
+ some useful operations (substitution, congruence,
+ coercion/cast). It also contains a type class for
+ producing equality proofs, providing some form of
+ decidable equality on types.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/type-equality/type-equality-1.ebuild b/dev-haskell/type-equality/type-equality-1.ebuild
new file mode 100644
index 000000000000..c59698cbe1e1
--- /dev/null
+++ b/dev-haskell/type-equality/type-equality-1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.1
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Type equality, coercion/cast and other operations"
+HOMEPAGE="https://github.com/hesselink/type-equality"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'base >=4.3 && <4.14' 'base >=4.3'
+}