summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:11:03 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:10:27 +0100
commit21b17f0e52b4aab37f399412efef7a7954190ecd (patch)
tree1e0e1f9c53205d739dd012f7970de842c41b2979 /dev-haskell
parentdev-haskell/x509-store: add 1.6.9 (diff)
downloadgentoo-21b17f0e52b4aab37f399412efef7a7954190ecd.tar.gz
gentoo-21b17f0e52b4aab37f399412efef7a7954190ecd.tar.bz2
gentoo-21b17f0e52b4aab37f399412efef7a7954190ecd.zip
dev-haskell/x509-system: add 1.6.7
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/x509-system/Manifest1
-rw-r--r--dev-haskell/x509-system/metadata.xml1
-rw-r--r--dev-haskell/x509-system/x509-system-1.6.7.ebuild27
3 files changed, 29 insertions, 0 deletions
diff --git a/dev-haskell/x509-system/Manifest b/dev-haskell/x509-system/Manifest
index eb1c23dd93d1..7e306acd4515 100644
--- a/dev-haskell/x509-system/Manifest
+++ b/dev-haskell/x509-system/Manifest
@@ -1 +1,2 @@
DIST x509-system-1.6.6.tar.gz 3419 BLAKE2B 12de162cfc29ddc0f0e5649e0531609bda73f0b0cb305e03015e037f7cb5cef7e4c9a2fa202396673f81e28084e6c4c52cd588cc1050e7bbd4cbe1116b916722 SHA512 110f8e9566ab1cd9491f1bc9cb11ee950c34308af026e71b9f8e60beac09b0e062e1e3a0177d67b04aab824c54476b800b965bf616fe84ba0181991371c9c220
+DIST x509-system-1.6.7.tar.gz 3438 BLAKE2B 74ba3138c21ea81a03deeb2c3b691238704ad8c275eeefc792ba4a79f0953fcea3466861df7f90f03d5e3435fa7fd4da3c342c5a3fbfa73c946929ad71c755c8 SHA512 8414d8f6d0e704419ccdd6832522480022bb15ac225b6bd9cf5f2d8fffb7f979d414bcb5c465f4d73d9eef40210ef9aa5da51aea9eed2ce245d2b44daf2c415e
diff --git a/dev-haskell/x509-system/metadata.xml b/dev-haskell/x509-system/metadata.xml
index adbae2cc1fad..436de7f6d64b 100644
--- a/dev-haskell/x509-system/metadata.xml
+++ b/dev-haskell/x509-system/metadata.xml
@@ -6,6 +6,7 @@
<name>Gentoo Haskell</name>
</maintainer>
<upstream>
+ <remote-id type="hackage">x509-system</remote-id>
<remote-id type="github">vincenthz/hs-certificate</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-haskell/x509-system/x509-system-1.6.7.ebuild b/dev-haskell/x509-system/x509-system-1.6.7.ebuild
new file mode 100644
index 000000000000..20c0a3d95752
--- /dev/null
+++ b/dev-haskell/x509-system/x509-system-1.6.7.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.0.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Handle per-operating-system X.509 accessors and storage"
+HOMEPAGE="https://github.com/vincenthz/hs-certificate"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-haskell/pem-0.1:=[profile?] <dev-haskell/pem-0.3:=[profile?]
+ || ( dev-lang/ghc dev-haskell/process[profile?] )
+ >=dev-haskell/x509-1.6:=[profile?]
+ >=dev-haskell/x509-store-1.6.2:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+"