summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jcmdline
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jcmdline')
-rw-r--r--dev-java/jcmdline/Manifest1
-rw-r--r--dev-java/jcmdline/files/jcmdline-1.0.2-gentoo.patch23
-rw-r--r--dev-java/jcmdline/jcmdline-1.0.2-r2.ebuild36
-rw-r--r--dev-java/jcmdline/metadata.xml12
4 files changed, 72 insertions, 0 deletions
diff --git a/dev-java/jcmdline/Manifest b/dev-java/jcmdline/Manifest
new file mode 100644
index 000000000000..c8d91e9a71b1
--- /dev/null
+++ b/dev-java/jcmdline/Manifest
@@ -0,0 +1 @@
+DIST jcmdline-1.0.2.zip 397472 SHA256 a042f7061c79629cdf298ee4f7b334c3ece9c1a4d87acf7c2f051ae0372bf43b SHA512 b261856eed9426257fd6391d45760f96f0085a40167632bfb2f85d35071e58d766553819bc0f8022b92fa193d47464928d09d2b0772a08ba484dd954b6206fd7 WHIRLPOOL a62bf4ab0c3e5236655d246a193135f23b52f692d1e1865d194dcaa03e1a0db6249f32142c212e34661d62fd2c4ae4714e18687b97f2bd2ab08141ff1c76ef3b
diff --git a/dev-java/jcmdline/files/jcmdline-1.0.2-gentoo.patch b/dev-java/jcmdline/files/jcmdline-1.0.2-gentoo.patch
new file mode 100644
index 000000000000..c0e593eca335
--- /dev/null
+++ b/dev-java/jcmdline/files/jcmdline-1.0.2-gentoo.patch
@@ -0,0 +1,23 @@
+--- build.xml.orig 2005-02-04 22:07:21.800581304 +0100
++++ build.xml 2005-02-04 22:11:43.734761256 +0100
+@@ -170,6 +170,11 @@
+ <echo message="jcmdline Unit Test docs have been written to ${docdir}/jcmdline/utapi" />
+ </target>
+
++ <target name="jar" depends="build">
++ <jar jarfile="${basedir}/jcmdline.jar"
++ basedir="${builddir}/classes" />
++ </target>
++
+ <!-- Don't distribute anything that will not pass UTs -->
+ <target name="dist" depends="clean, ut, doc"
+ description="prepare distribution files">
+@@ -203,8 +208,6 @@
+ </copy>
+
+ <!-- add the jar =====================================================-->
+- <jar jarfile="${tmpDistBuildDir}/${projRelease}.jar"
+- basedir="${builddir}/classes" />
+
+ <!-- create a gzipped tarball for the Unix crowd =====================-->
+ <tar tarfile="${distdir}/${projRelease}.tar"
diff --git a/dev-java/jcmdline/jcmdline-1.0.2-r2.ebuild b/dev-java/jcmdline/jcmdline-1.0.2-r2.ebuild
new file mode 100644
index 000000000000..6eeb6a8b25d8
--- /dev/null
+++ b/dev-java/jcmdline/jcmdline-1.0.2-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Library for parsing/handling of command line parameters"
+HOMEPAGE="http://jcmdline.sourceforge.net/"
+SRC_URI="mirror://sourceforge/jcmdline/${P}.zip"
+LICENSE="MPL-1.1"
+SLOT="1.0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip"
+RDEPEND=">=virtual/jre-1.4"
+
+EANT_DOC_TARGET="doc"
+
+java_prepare() {
+ find -name "*.jar" -delete || die
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+}
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+
+ dodoc CHANGES CREDITS README
+ use doc && java-pkg_dojavadoc doc/jcmdline/api
+ use source && java-pkg_dosrc src/*
+}
diff --git a/dev-java/jcmdline/metadata.xml b/dev-java/jcmdline/metadata.xml
new file mode 100644
index 000000000000..df9de2927648
--- /dev/null
+++ b/dev-java/jcmdline/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <longdescription>
+ This package facilitates parsing/handling of command line parameters
+ with an aim at adding consistency across various applications.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">jcmdline</remote-id>
+ </upstream>
+</pkgmetadata>