summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-06-15 08:16:12 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-06-20 08:49:25 +0200
commit814848b7060d05539e395d8c3e5d9409b8b89e09 (patch)
treeb1666e83f9e18baf7aef22547dab7ee4e85c8304 /dev-java/jdbc-postgresql
parentdev-java/scram: new package, add 2.1 (diff)
downloadgentoo-814848b7060d05539e395d8c3e5d9409b8b89e09.tar.gz
gentoo-814848b7060d05539e395d8c3e5d9409b8b89e09.tar.bz2
gentoo-814848b7060d05539e395d8c3e5d9409b8b89e09.zip
dev-java/jdbc-postgresql: add 42.4.0
Bug: https://bugs.gentoo.org/727906 Closes: https://bugs.gentoo.org/851993 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/25911 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-java/jdbc-postgresql')
-rw-r--r--dev-java/jdbc-postgresql/Manifest1
-rw-r--r--dev-java/jdbc-postgresql/jdbc-postgresql-42.4.0.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-java/jdbc-postgresql/Manifest b/dev-java/jdbc-postgresql/Manifest
index 04c1f8e9ea24..bc169c1a1736 100644
--- a/dev-java/jdbc-postgresql/Manifest
+++ b/dev-java/jdbc-postgresql/Manifest
@@ -1 +1,2 @@
+DIST postgresql-jdbc-42.4.0.src.tar.gz 966868 BLAKE2B 0a8bffcfbba4ddedcbd77717b6bca2f4e7cd9fe4597c6edb5a2ac8fbea788c692377ae713723aa7342895f857aff7eca0825eedd36cff69f3760b11cbb7b666c SHA512 816967923f54d5c2ad856e3ae2612987fa52234acc6b487f492d56614ac241d9542abd40a1f868ad6d895a45de28f7a0d586f8486dc719600238bcc3ef40819a
DIST postgresql-jdbc-9.4-1206.src.tar.gz 2029837 BLAKE2B b222a0b2f8f99becaf0ae350407fafeb23d9d4bdb130c17996373b4211e0d56d1a76bc5737401dc6fc6618d2a891943d096b0f60f0770ff6ce859ade3e7a178d SHA512 b16816f1afd3ee5986fca197bd7608c2e2f334054e41a8c541c47985827f4f59d7691d23983bdac01c85fc364cd001c991ac6b4e8567429b9d1f4161388dd6bd
diff --git a/dev-java/jdbc-postgresql/jdbc-postgresql-42.4.0.ebuild b/dev-java/jdbc-postgresql/jdbc-postgresql-42.4.0.ebuild
new file mode 100644
index 000000000000..9ebc3e1125bf
--- /dev/null
+++ b/dev-java/jdbc-postgresql/jdbc-postgresql-42.4.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri https://jdbc.postgresql.org/download/postgresql-jdbc-42.4.0.src.tar.gz --slot 0 --keywords "~amd64 ~ppc64 ~x86" --ebuild jdbc-postgresql-42.4.0.ebuild
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+MAVEN_ID="org.postgresql:postgresql:42.4.0"
+# We don't have junit-vintage and junit-jupiter.
+# JAVA_TESTING_FRAMEWORKS="junit-vintage junit-jupiter junit-4"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Java JDBC 4.2 (JRE 8+) driver for PostgreSQL database"
+HOMEPAGE="https://github.com/pgjdbc/pgjdbc"
+SRC_URI="https://jdbc.postgresql.org/download/postgresql-jdbc-${PV}.src.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+# Common dependencies
+# POM: pom.xml
+# com.ongres.scram:client:2.1 -> !!!groupId-not-found!!!
+# uk.org.webcompere:system-stubs-jupiter:1.2.0 -> !!!groupId-not-found!!!
+
+CP_DEPEND="dev-java/scram:0"
+
+# Compile dependencies
+# POM: pom.xml
+# test? junit:junit:4.13 -> >=dev-java/junit-4.13.2:4
+# test? org.junit.jupiter:junit-jupiter-api:5.6.0 -> !!!groupId-not-found!!!
+# test? org.junit.jupiter:junit-jupiter-engine:5.6.0 -> !!!groupId-not-found!!!
+# test? org.junit.jupiter:junit-jupiter-params:5.6.0 -> !!!groupId-not-found!!!
+# test? org.junit.vintage:junit-vintage-engine:5.6.0 -> !!!groupId-not-found!!!
+# test? se.jiderhamn:classloader-leak-test-framework:1.1.1 -> !!!groupId-not-found!!!
+
+DEPEND="
+ >=virtual/jdk-1.8:*
+ ${CP_DEPEND}"
+# test? (
+# !!!groupId-not-found!!!
+# )
+# "
+
+RDEPEND="
+ >=virtual/jre-1.8:*
+ ${CP_DEPEND}"
+
+S="${WORKDIR}/postgresql-${PV}-jdbc-src"
+
+JAVA_SRC_DIR="src/main/java"
+JAVA_RESOURCE_DIRS="src/main/resources"
+
+# JAVA_TEST_GENTOO_CLASSPATH="junit-4,!!!groupId-not-found!!!,!!!groupId-not-found!!!,!!!groupId-not-found!!!,!!!groupId-not-found!!!,!!!groupId-not-found!!!"
+# JAVA_TEST_SRC_DIR="src/test/java"
+# JAVA_TEST_RESOURCE_DIRS="src/test/resources"