summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-07-24 17:46:36 +0200
committerSam James <sam@gentoo.org>2022-07-25 01:27:51 +0100
commit32a4721f0f3891663540ad831c3c6923cafed8c4 (patch)
treefb2b8b4bbe71a144c79a28953b49c102f811218d /dev-java/jffi
parentsys-apps/logwatch: add 7.7 (diff)
downloadgentoo-32a4721f0f3891663540ad831c3c6923cafed8c4.tar.gz
gentoo-32a4721f0f3891663540ad831c3c6923cafed8c4.tar.bz2
gentoo-32a4721f0f3891663540ad831c3c6923cafed8c4.zip
dev-java/jffi: depend on >=dev-libs/libffi-3.4.2-r2
3.4.2-r1 was causing issues on PPC64. Bug: https://bugs.gentoo.org/827215 Bug: https://github.com/jnr/jffi/issues/107 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/26568 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-java/jffi')
-rw-r--r--dev-java/jffi/jffi-1.3.9-r1.ebuild99
1 files changed, 99 insertions, 0 deletions
diff --git a/dev-java/jffi/jffi-1.3.9-r1.ebuild b/dev-java/jffi/jffi-1.3.9-r1.ebuild
new file mode 100644
index 000000000000..0655be95b313
--- /dev/null
+++ b/dev-java/jffi/jffi-1.3.9-r1.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri https://github.com/jnr/jffi/archive/jffi-1.3.9.tar.gz --slot 1.3 --keywords "~amd64 ~arm64 ~ppc64 ~x86" --ebuild jffi-1.3.9.ebuild
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source test"
+MAVEN_ID="com.github.jnr:jffi:1.3.9"
+JAVA_TESTING_FRAMEWORKS="junit-4"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Java Foreign Function Interface"
+HOMEPAGE="https://github.com/jnr/jffi"
+SRC_URI="https://github.com/jnr/${PN}/archive/refs/tags/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="1.3"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+DEPEND=">=virtual/jdk-1.8:*
+ >=dev-libs/libffi-3.4.2-r2:="
+RDEPEND=">=virtual/jre-1.8:*
+ >=dev-libs/libffi-3.4.2-r2:="
+
+PATCHES=( "${FILESDIR}"/jffi-1.3.8-GNUmakefile.patch )
+
+S="${WORKDIR}/${PN}-${P}"
+
+JAVA_SRC_DIR="src/main/java"
+
+# https://github.com/jnr/jffi/blob/b6ad5c066a6346072ea04f8ffa8177204aadcb13/build.xml#L26
+JAVA_TEST_EXTRA_ARGS="-Djffi.library.path=${S}/build/jni -Djffi.boot.library.path=${S}/build/jni"
+JAVA_TEST_GENTOO_CLASSPATH="junit-4"
+JAVA_TEST_SRC_DIR="src/test/java"
+
+src_prepare() {
+ default
+ cat > src/main/java/com/kenai/jffi/Version.java <<-EOF
+ package com.kenai.jffi;
+ import java.lang.annotation.Native;
+ public final class Version {
+ private Version() {}
+ @Native
+ public static final int MAJOR = $(ver_cut 1);
+ @Native
+ public static final int MINOR = $(ver_cut 2);
+ @Native
+ public static final int MICRO = $(ver_cut 3);
+ }
+ EOF
+}
+
+src_compile() {
+ java-pkg-simple_src_compile
+
+ # generate headers
+ mkdir -p build/jni
+ javac -h build/jni -classpath target/classes \
+ ${JAVA_SRC_DIR}/com/kenai/jffi/{Foreign,ObjectBuffer,Version}.java \
+ || die
+
+ #build native library.
+ local args=(
+ SRC_DIR=jni
+ JNI_DIR=jni
+ BUILD_DIR=build/jni
+ VERSION=$(ver_cut 1-2)
+ USE_SYSTEM_LIBFFI=1
+ CCACHE=
+ -f jni/GNUmakefile
+ )
+ emake "${args[@]}"
+}
+
+src_test() {
+ # build native test library
+ emake BUILD_DIR=build -f libtest/GNUmakefile
+
+ # https://github.com/jnr/jffi/issues/60
+ LC_ALL=C java-pkg-simple_src_test
+}
+
+src_install() {
+ default
+
+ local libname=".so"
+ java-pkg_doso build/jni/lib${PN}-$(ver_cut 1-2)${libname}
+
+ # must be after _doso to have JAVA_PKG_LIBDEST set
+ cat > boot.properties <<-EOF
+ jffi.boot.library.path = ${JAVA_PKG_LIBDEST}
+ EOF
+ jar -uf ${PN}.jar boot.properties || die
+
+ java-pkg-simple_src_install
+}