summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jgoodies-forms
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jgoodies-forms')
-rw-r--r--dev-java/jgoodies-forms/Manifest2
-rw-r--r--dev-java/jgoodies-forms/jgoodies-forms-1.3.0-r1.ebuild44
-rw-r--r--dev-java/jgoodies-forms/jgoodies-forms-1.3.0.ebuild57
-rw-r--r--dev-java/jgoodies-forms/jgoodies-forms-1.8.0.ebuild40
-rw-r--r--dev-java/jgoodies-forms/metadata.xml6
5 files changed, 149 insertions, 0 deletions
diff --git a/dev-java/jgoodies-forms/Manifest b/dev-java/jgoodies-forms/Manifest
new file mode 100644
index 000000000000..55cf18c64d9f
--- /dev/null
+++ b/dev-java/jgoodies-forms/Manifest
@@ -0,0 +1,2 @@
+DIST forms-1_3_0.zip 1320397 SHA256 f707a074264c43e37dce7c42df24e433d089fab828a673bf264082397d1f5329 SHA512 d155cc85ec77f23f55e59d4651ef1f9df2ab749bc6cffd4dd7cfbc0035587a2e6bf03427e7bace6feb71e6c43efc87115d393fa54ea6da331ded21996b32a6e8 WHIRLPOOL 88c6aab03ab8e640bb74360c9ff96e3f6da2e64e4da29c851217e6588ffe625c7c73e2ede6ef211eb6a7bfe32ab46370edefb8eed6ff8bc06e875e50e8e33a46
+DIST jgoodies-forms-1_8_0.zip 1668539 SHA256 b090e455727fb2c2ecd1a6bb09b12d5c9f62f662d14b5a53d8b5cbd06fe064ab SHA512 dced4ddaea7e9157f99b7c27ad06bfed53c307181bfc21cee8f454ba8cececa3f5fd5186947fe5bb299c4de2032bd7489248e3e77623785ac47388306e3d6933 WHIRLPOOL 1e38380d171b381f94b3bec2bd4d492088755f40152555f6bd0f281042bec289373045d278f9e1634f5a05e554f7fa80676b6dfaf532ddbd5bde13abd343e37b
diff --git a/dev-java/jgoodies-forms/jgoodies-forms-1.3.0-r1.ebuild b/dev-java/jgoodies-forms/jgoodies-forms-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..8192263eb065
--- /dev/null
+++ b/dev-java/jgoodies-forms/jgoodies-forms-1.3.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc examples source"
+
+inherit java-pkg-2 java-ant-2
+
+MY_PN="forms"
+MY_PV=${PV//./_}
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="JGoodies Forms Library"
+HOMEPAGE="http://www.jgoodies.com/"
+SRC_URI="http://www.jgoodies.com/download/libraries/${MY_PN}/${MY_P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x64-macos"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip"
+RDEPEND=">=virtual/jre-1.4"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+EANT_FILTER_COMPILTER="jikes"
+
+java_prepare() {
+ find -name "*.jar" -delete || die
+}
+
+src_install() {
+ java-pkg_dojar build/${MY_PN}.jar
+
+ dodoc RELEASE-NOTES.txt README.html || die
+
+ use doc && java-pkg_dohtml -r docs/*
+ use source && java-pkg_dosrc src/{core,extras}/com
+ use examples && java-pkg_doexamples src/tutorial
+}
diff --git a/dev-java/jgoodies-forms/jgoodies-forms-1.3.0.ebuild b/dev-java/jgoodies-forms/jgoodies-forms-1.3.0.ebuild
new file mode 100644
index 000000000000..db3897209d9a
--- /dev/null
+++ b/dev-java/jgoodies-forms/jgoodies-forms-1.3.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc examples source"
+
+inherit java-pkg-2 java-ant-2 eutils
+
+MY_PN="forms"
+MY_PV=${PV//./_}
+MY_P="${MY_PN}-${MY_PV}"
+DESCRIPTION="JGoodies Forms Library"
+HOMEPAGE="http://www.jgoodies.com/"
+SRC_URI="http://www.jgoodies.com/download/libraries/${MY_PN}/${MY_P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd ~x64-macos"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip"
+RDEPEND=">=virtual/jre-1.4"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_unpack() {
+ unpack ${A} || die "Unpack failed"
+ cd "${S}"
+
+ # Remove the packaged jars
+ rm -v *.jar || die "rm failed"
+}
+
+src_compile() {
+ # it does not like unset ${build.compiler.executable}
+ # feel free to fix if you want jikes back
+ java-pkg_filter-compiler jikes
+ # not setting the bootcp breaks ecj, javac apparently ignores nonsense
+ eant -Dbuild.boot.classpath="$(java-config -g BOOTCLASSPATH)" jar
+}
+
+#Needs X
+#src_test() {
+# ANT_TASKS="ant-junit" eant test \
+# -Djunit.jar="$(java-pkg_getjars junit)"
+#}
+
+src_install() {
+ java-pkg_dojar build/${MY_PN}.jar
+
+ dodoc RELEASE-NOTES.txt README.html || die
+
+ use doc && java-pkg_dohtml -r docs/*
+ use source && java-pkg_dosrc src/{core,extras}/com
+ use examples && java-pkg_doexamples src/tutorial
+}
diff --git a/dev-java/jgoodies-forms/jgoodies-forms-1.8.0.ebuild b/dev-java/jgoodies-forms/jgoodies-forms-1.8.0.ebuild
new file mode 100644
index 000000000000..e014cf0f0adf
--- /dev/null
+++ b/dev-java/jgoodies-forms/jgoodies-forms-1.8.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+MY_PN="forms"
+MY_PV=${PV//./_}
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="JGoodies Forms Library"
+HOMEPAGE="http://www.jgoodies.com/"
+SRC_URI="http://www.jgoodies.com/download/libraries/${MY_PN}/${MY_P}.zip"
+
+LICENSE="BSD"
+SLOT="1.8"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="dev-java/jgoodies-common:${SLOT}"
+DEPEND=">=virtual/jdk-1.6
+ app-arch/unzip
+ ${COMMON_DEPEND}"
+RDEPEND=">=virtual/jre-1.6
+ ${COMMON_DEPEND}"
+
+S="${WORKDIR}"/${P}
+
+JAVA_SRC_DIR="src"
+JAVA_GENTOO_CLASSPATH="jgoodies-common-${SLOT}"
+
+java_prepare() {
+ mkdir src || die
+ unzip ${P}-sources.jar -d src || die
+ rm "${S}"/pom.xml "${S}"/*.jar || die
+}
diff --git a/dev-java/jgoodies-forms/metadata.xml b/dev-java/jgoodies-forms/metadata.xml
new file mode 100644
index 000000000000..604e0a4238bb
--- /dev/null
+++ b/dev-java/jgoodies-forms/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+</pkgmetadata>
+