summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2024-11-05 08:58:19 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2024-11-07 08:41:46 +0100
commit390c14f0f29de6ecba8e59366f9553883de1f79b (patch)
treed596d6ea989859ccc2c9cc5714153edf9c966a6d /dev-java/junitparams
parentapp-office/homebank: Stabilize 5.8.5 ppc, #942971 (diff)
downloadgentoo-390c14f0f29de6ecba8e59366f9553883de1f79b.tar.gz
gentoo-390c14f0f29de6ecba8e59366f9553883de1f79b.tar.bz2
gentoo-390c14f0f29de6ecba8e59366f9553883de1f79b.zip
dev-java/junitparams: style update, update EAPI 7 -> 8
Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/39208/commits/f08a8ea6c881a4c9536979101152be82e095de08 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java/junitparams')
-rw-r--r--dev-java/junitparams/junitparams-1.1.1-r2.ebuild (renamed from dev-java/junitparams/junitparams-1.1.1-r1.ebuild)30
1 files changed, 9 insertions, 21 deletions
diff --git a/dev-java/junitparams/junitparams-1.1.1-r1.ebuild b/dev-java/junitparams/junitparams-1.1.1-r2.ebuild
index 9b511a320bec..0b40cf5e590e 100644
--- a/dev-java/junitparams/junitparams-1.1.1-r1.ebuild
+++ b/dev-java/junitparams/junitparams-1.1.1-r2.ebuild
@@ -1,10 +1,7 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# Skeleton command:
-# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri https://github.com/Pragmatists/JUnitParams/archive/refs/tags/JUnitParams-1.1.1.tar.gz --slot 0 --keywords "~amd64 ~arm64 ~ppc64 ~x86" --ebuild junitparams-1.1.1.ebuild
-
-EAPI=7
+EAPI=8
JAVA_PKG_IUSE="doc source test"
MAVEN_ID="pl.pragmatists:JUnitParams:1.1.1"
@@ -14,22 +11,15 @@ inherit java-pkg-2 java-pkg-simple
DESCRIPTION="Better parameterised tests for JUnit"
HOMEPAGE="https://github.com/Pragmatists/JUnitParams"
-SRC_URI="https://github.com/Pragmatists/JUnitParams/archive/refs/tags/JUnitParams-${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/Pragmatists/JUnitParams/archive/JUnitParams-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/JUnitParams-JUnitParams-${PV}"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 arm64 ppc64"
-# Common dependencies
-# POM: pom.xml
-# junit:junit:4.12 -> >=dev-java/junit-4.12:4
-
CP_DEPEND="dev-java/junit:4"
-# Compile dependencies
-# POM: pom.xml
-# test? org.assertj:assertj-core:1.7.1 -> >=dev-java/assertj-core-2.3.0:2
-
DEPEND="
>=virtual/jdk-1.8:*
${CP_DEPEND}
@@ -40,19 +30,16 @@ DEPEND="
RDEPEND="
>=virtual/jre-1.8:*
- ${CP_DEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/junitparams-1.1.1-test.patch
-)
+ ${CP_DEPEND}
+"
-S="${WORKDIR}/JUnitParams-JUnitParams-${PV}"
+PATCHES=( "${FILESDIR}"/junitparams-1.1.1-test.patch )
JAVA_SRC_DIR="src/main/java"
JAVA_TEST_GENTOO_CLASSPATH="assertj-core-3"
-JAVA_TEST_SRC_DIR="src/test/java"
JAVA_TEST_RESOURCE_DIRS="src/test/resources"
+JAVA_TEST_SRC_DIR="src/test/java"
JAVA_TEST_EXCLUDES=(
# java.lang.RuntimeException: Could not find method: paramsForSuperclassMethod so no params were used.
@@ -60,5 +47,6 @@ JAVA_TEST_EXCLUDES=(
)
src_prepare() {
- default
+ default #780585
+ java-pkg-2_src_prepare
}