summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/rxtx/rxtx-2.1.7.2-r3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/rxtx/rxtx-2.1.7.2-r3.ebuild')
-rw-r--r--dev-java/rxtx/rxtx-2.1.7.2-r3.ebuild100
1 files changed, 100 insertions, 0 deletions
diff --git a/dev-java/rxtx/rxtx-2.1.7.2-r3.ebuild b/dev-java/rxtx/rxtx-2.1.7.2-r3.ebuild
new file mode 100644
index 000000000000..149fb25528cb
--- /dev/null
+++ b/dev-java/rxtx/rxtx-2.1.7.2-r3.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit flag-o-matic toolchain-funcs versionator autotools java-pkg-2
+
+MY_PV="$(replace_version_separator 2 -)"
+MY_PV="$(replace_version_separator 3 r ${MY_PV})"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Native lib providing serial and parallel communication for Java"
+HOMEPAGE="http://rxtx.qbang.org/"
+SRC_URI="ftp://ftp.qbang.org/pub/rxtx/${MY_P}.zip"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="amd64 x86"
+IUSE="doc source lfd"
+
+RDEPEND=">=virtual/jre-1.4"
+
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip
+ dev-java/ant-core
+ lfd? ( sys-apps/xinetd )
+ source? ( app-arch/zip )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # some minor fixes
+ sed -i -e "s:UTS_RELEASE::g" configure.in
+ sed -i -e "s:|1.5\*:|1.5*|1.6*|1.7*:g" configure.in
+ sed -i -e "s:\(\$(JAVADOC)\):\1 -d api:g" Makefile.am
+
+ # some patches
+ epatch "${FILESDIR}/${MY_P}-lfd.diff" \
+ "${FILESDIR}/${MY_P}-nouts.diff" \
+ "${FILESDIR}/${MY_P}-add-ttyACM.diff" \
+ "${FILESDIR}/${MY_P}-lfd-include-limits.diff"
+
+ # update autotools stuff
+ rm acinclude.m4
+ eautoreconf
+ elibtoolize
+}
+
+src_compile() {
+ econf $(use_enable lfd lockfile_server) || die "econf failed"
+ emake || die "emake failed"
+
+ if use lfd; then
+ # see INSTALL in src/ldf
+ $(tc-getCC) ${LDFLAGS} ${CFLAGS} src/lfd/lockdaemon.c -o src/lfd/in.lfd || die "compiling lfd failed"
+ fi
+
+ if use doc; then
+ emake docs || die "failed to emake docs"
+ fi
+
+ #Fix for src zip creation
+ if use source; then
+ mkdir -p src_with_pkg/gnu
+ ln -s ../../src src_with_pkg/gnu/io
+ fi
+}
+
+src_install() {
+ java-pkg_dojar RXTXcomm.jar
+ java-pkg_doso ${CHOST}/.libs/*.so
+
+ dodoc AUTHORS ChangeLog INSTALL PORTING TODO SerialPortInstructions.txt
+ dohtml RMISecurityManager.html
+
+ if use lfd; then
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}/lockfiled.xinetd" lfd
+ dosbin src/lfd/in.lfd
+ dodoc src/lfd/LockFileServer.rfc
+ fi
+
+ use doc && java-pkg_dojavadoc api
+ use source && java-pkg_dosrc src_with_pkg/gnu
+}
+
+pkg_postinst() {
+ if use lfd; then
+ elog "Don't forget to enable the LockFileServer"
+ elog "daemon (lfd) in /etc/xinetd.d/lfd"
+ else
+ elog "RXTX uses UUCP style device-locks. You should"
+ elog "add every user who needs to access serial ports"
+ elog "to the 'uucp' group:"
+ elog
+ elog " usermod -aG uucp <user>"
+ fi
+}