summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-04-19 10:30:43 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-04-19 10:33:19 +0200
commita92e6918e7a104c40f8eaaebe1b8f032f07311a4 (patch)
tree21938eb6fb0abaf338e741558f694af296dd635e /dev-java
parentdev-lang/spidermonkey: bump to v78.10.0 (diff)
downloadgentoo-a92e6918e7a104c40f8eaaebe1b8f032f07311a4.tar.gz
gentoo-a92e6918e7a104c40f8eaaebe1b8f032f07311a4.tar.bz2
gentoo-a92e6918e7a104c40f8eaaebe1b8f032f07311a4.zip
dev-java/commons-text: new package
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/commons-text/Manifest1
-rw-r--r--dev-java/commons-text/commons-text-1.9.ebuild43
-rw-r--r--dev-java/commons-text/metadata.xml8
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-java/commons-text/Manifest b/dev-java/commons-text/Manifest
new file mode 100644
index 000000000000..e99bcc4b22d1
--- /dev/null
+++ b/dev-java/commons-text/Manifest
@@ -0,0 +1 @@
+DIST commons-text-1.9-sources.tar.gz 312764 BLAKE2B 44b628c418a910ff38b5a1fb3b4c9f14a1f9818afd12540f8c8cf8b1a99fd7abd365e704142bcec901e5e067b303ff44f9c992f8714eae68b94819780a270dd2 SHA512 53f993e79aaa6789d3388aa96b6b2a14cf646b27ff3774524390e511241a85288947cc929519eff61a8734578f25bdf3d9969d84da20c1a749b19d90a55da8ae
diff --git a/dev-java/commons-text/commons-text-1.9.ebuild b/dev-java/commons-text/commons-text-1.9.ebuild
new file mode 100644
index 000000000000..8671f21cf484
--- /dev/null
+++ b/dev-java/commons-text/commons-text-1.9.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri https://downloads.apache.org//commons/text/source/commons-text-1.9-src.tar.gz --slot 0 --keywords "~amd64 ~x86" --ebuild commons-text-1.9.ebuild
+
+EAPI=7
+
+JAVA_PKG_IUSE="doc source"
+MAVEN_ID="org.apache.commons:commons-text:1.9"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Apache Commons Text is a library focused on algorithms working on strings."
+HOMEPAGE="https://commons.apache.org/proper/commons-text"
+SRC_URI="https://downloads.apache.org//commons/text/source/${P}-src.tar.gz -> ${P}-sources.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Common dependencies
+# POM: pom.xml
+# org.apache.commons:commons-lang3:3.11 -> >=dev-java/commons-lang-3.11:3.6
+
+CDEPEND="
+ >=dev-java/commons-lang-3.11:3.6
+"
+
+DEPEND="
+ >=virtual/jdk-1.8:*
+ ${CDEPEND}
+"
+
+RDEPEND="
+ >=virtual/jre-1.8:*
+ ${CDEPEND}"
+
+S="${WORKDIR}/${P}-src"
+
+JAVA_ENCODING="ISO-8859-1"
+
+JAVA_GENTOO_CLASSPATH="commons-lang-3.6"
+JAVA_SRC_DIR="src/main/java"
diff --git a/dev-java/commons-text/metadata.xml b/dev-java/commons-text/metadata.xml
new file mode 100644
index 000000000000..952a4b9b605c
--- /dev/null
+++ b/dev-java/commons-text/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>java@gentoo.org</email>
+ <name>Java</name>
+ </maintainer>
+</pkgmetadata>