summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Gillespie <tgbugs@gmail.com>2020-01-03 02:39:38 -0500
committerKent Fredric <kentnl@gentoo.org>2020-04-23 17:01:40 +1200
commitbc84204dcf51429f908eed0e595313421d8a7bc4 (patch)
tree701a3ed965cda59ea9db8ee6aee0798d6d08f832 /dev-java
parentdev-perl/Algorithm-Diff: Add -r bump for EAPI7 (diff)
downloadgentoo-bc84204dcf51429f908eed0e595313421d8a7bc4.tar.gz
gentoo-bc84204dcf51429f908eed0e595313421d8a7bc4.tar.bz2
gentoo-bc84204dcf51429f908eed0e595313421d8a7bc4.zip
dev-java/spec-alpha: new package for clojure build
>=clojure-1.9.0 depends on dev-java/spec-alpha This commit includes an ant build.xml file so that no maven dependencies are needed. Signed-off-by: Tom Gillespie <tgbugs@gmail.com> Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/spec-alpha/Manifest2
-rw-r--r--dev-java/spec-alpha/files/build.xml37
-rw-r--r--dev-java/spec-alpha/metadata.xml15
-rw-r--r--dev-java/spec-alpha/spec-alpha-0.1.143.ebuild41
-rw-r--r--dev-java/spec-alpha/spec-alpha-0.2.176.ebuild41
5 files changed, 136 insertions, 0 deletions
diff --git a/dev-java/spec-alpha/Manifest b/dev-java/spec-alpha/Manifest
new file mode 100644
index 000000000000..5705ccaf4b0b
--- /dev/null
+++ b/dev-java/spec-alpha/Manifest
@@ -0,0 +1,2 @@
+DIST spec-alpha-0.1.143.tar.gz 35568 BLAKE2B f63fdd2b3c83dbd3936e36ff57b6ea399b7173fe805c60a6ecbd8e4aef5942f051a8551c259d89885a202c20045f67921b66c4dc9e361aacc8903c6542d7c7b5 SHA512 87887d72bc7343f96fad937b90feb4cc1be1eeaad8b7c01ae090ebe5cb17c30612e63797ea9eb39e6fe4c07870dcba9e153a98777d372923e95163f3219a976c
+DIST spec-alpha-0.2.176.tar.gz 37055 BLAKE2B 0588772e4a47a5b122984abefaf5ef2d0fffbacaf277b22737c94889e646c16a029017d405b72b829e88bcf03b12f689cb2053884b24b47193a26978ab54a318 SHA512 decf0dbff09bf8ee12503e6117ab635b98cd8dd2c389acf7aeebf00f32b5fd8250d66c2ec54cfe5da45e727e39480ae738a3ee7fcad71684d8c3acf464fe21e7
diff --git a/dev-java/spec-alpha/files/build.xml b/dev-java/spec-alpha/files/build.xml
new file mode 100644
index 000000000000..ea47d06b77d2
--- /dev/null
+++ b/dev-java/spec-alpha/files/build.xml
@@ -0,0 +1,37 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<project name="spec.alpha" default="package" basedir=".">
+ <property name="maven.build.finalName" value="spec.alpha-SNAPSHOT"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/clojure"/>
+
+ <!-- clean -->
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- build -->
+ <target name="build" description="Copy the files">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <copy todir="${maven.build.outputDir}">
+ <fileset dir="${maven.build.srcDir.0}"/>
+ </copy>
+ </target>
+
+ <!-- package -->
+ <target name="package" depends="build" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html"/>
+ </target>
+
+ <!-- jar -->
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+</project>
diff --git a/dev-java/spec-alpha/metadata.xml b/dev-java/spec-alpha/metadata.xml
new file mode 100644
index 000000000000..d7856d86ee56
--- /dev/null
+++ b/dev-java/spec-alpha/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tgbugs@gmail.com</email>
+ <name>Tom Gillespie</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">clojure/spec.alpha</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-java/spec-alpha/spec-alpha-0.1.143.ebuild b/dev-java/spec-alpha/spec-alpha-0.1.143.ebuild
new file mode 100644
index 000000000000..d4a4e473b091
--- /dev/null
+++ b/dev-java/spec-alpha/spec-alpha-0.1.143.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit java-pkg-2 java-ant-2
+
+EGIT_REF="51b64c0"
+
+MY_PN=${PN//-/.}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="A Clojure library to describe the structure of data and functions."
+HOMEPAGE="https://clojure.org/ https://github.com/clojure/spec.alpha"
+SRC_URI="https://github.com/clojure/${MY_PN}/archive/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="EPL-1.0"
+SLOT="0.1"
+KEYWORDS="~amd64 ~x86 ~x86-linux"
+IUSE=""
+
+CDEPEND="dev-java/ant-core:0"
+RDEPEND=">=virtual/jre-1.8:*"
+DEPEND="
+ ${CDEPEND}
+ >=virtual/jdk-1.8:*"
+
+S="${WORKDIR}/${MY_PN}-${MY_P}"
+
+EANT_TASKS="jar"
+EANT_EXTRA_ARGS="-Dmaven.build.finalName=${MY_P}"
+
+src_prepare() {
+ default
+ cp "${FILESDIR}/build.xml" . || die
+}
+
+src_install() {
+ java-pkg_newjar "target/${MY_P}.jar"
+ dodoc CONTRIBUTING.md README.md
+}
diff --git a/dev-java/spec-alpha/spec-alpha-0.2.176.ebuild b/dev-java/spec-alpha/spec-alpha-0.2.176.ebuild
new file mode 100644
index 000000000000..5558df7e2a14
--- /dev/null
+++ b/dev-java/spec-alpha/spec-alpha-0.2.176.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit java-pkg-2 java-ant-2
+
+EGIT_REF="59af4cf"
+
+MY_PN=${PN//-/.}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="A Clojure library to describe the structure of data and functions."
+HOMEPAGE="https://clojure.org/ https://github.com/clojure/spec.alpha"
+SRC_URI="https://github.com/clojure/${MY_PN}/archive/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="EPL-1.0"
+SLOT="0.2"
+KEYWORDS="~amd64 ~x86 ~x86-linux"
+IUSE=""
+
+CDEPEND="dev-java/ant-core:0"
+RDEPEND=">=virtual/jre-1.8:*"
+DEPEND="
+ ${CDEPEND}
+ >=virtual/jdk-1.8:*"
+
+S="${WORKDIR}/${MY_PN}-${MY_P}"
+
+EANT_TASKS="jar"
+EANT_EXTRA_ARGS="-Dmaven.build.finalName=${MY_P}"
+
+src_prepare() {
+ default
+ cp "${FILESDIR}/build.xml" . || die
+}
+
+src_install() {
+ java-pkg_newjar "target/${MY_P}.jar"
+ dodoc CONTRIBUTING.md README.md
+}