summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2022-03-08 15:25:18 +0100
committerJoonas Niilola <juippis@gentoo.org>2022-03-11 10:31:01 +0200
commit8ed4e9fa9da6bd6472c87281319a0926c1e005fb (patch)
tree40f298cce1c960225d5a240826acc81bd204d55c /dev-lang/execline
parentdev-libs/skalibs: add 2.11.2.0 (diff)
downloadgentoo-8ed4e9fa9da6bd6472c87281319a0926c1e005fb.tar.gz
gentoo-8ed4e9fa9da6bd6472c87281319a0926c1e005fb.tar.bz2
gentoo-8ed4e9fa9da6bd6472c87281319a0926c1e005fb.zip
dev-lang/execline: add 2.8.3.0
Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-lang/execline')
-rw-r--r--dev-lang/execline/Manifest1
-rw-r--r--dev-lang/execline/execline-2.8.3.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-lang/execline/Manifest b/dev-lang/execline/Manifest
index 04a0a23d76da..e85a888badda 100644
--- a/dev-lang/execline/Manifest
+++ b/dev-lang/execline/Manifest
@@ -1,2 +1,3 @@
DIST execline-2.6.1.1.tar.gz 92495 BLAKE2B 6b901819e49c424d52ce2d87b6b42aec1595fb97fef7905e93eca2f3ac029a35f826e37e519e2c6ab9e2638f625a446db363f5fbfd5530a93b52c831660b7a11 SHA512 5826abb407742ad8a2cd48c09b966827d129dda420db07c893cd7a27e806441d7b117a0c61fdc0222e527aada976da26e4779a4896fc084cdf6efa8294ffac5b
DIST execline-2.8.2.0.tar.gz 98438 BLAKE2B 66860a1abb3f8078bd625d13dda2caec71bc41d54a35275548897018818b8b881b37d4ab4f4dd7a9a36386802f1f830d345e7ade0e9638b49acc80314ae60ae1 SHA512 9a2c21fbddfc4bce69857fa906fcbb7b17b0cd1009a33a9f3bbcce69ff443af82704d74b792e2d4393eb6d7de9888a5bc74ff208c31485d3398b0dea07368a15
+DIST execline-2.8.3.0.tar.gz 98448 BLAKE2B f3dc1a194838f7973044b2d86e6026936697be4f34f9b01f5dfc98ddabfbde3dad7cfe95afd63f65cb266994b922d7d4c94368cf5dca2a2494fd0033b4ed6032 SHA512 40f4697a8165616848ed36dcb31a5859dee55a47439d13908a387550e8f53ca8fffe3bcb3e0462cb93f694c8fb483b14e152f92e6f9d0d536cdab9d94be9c53a
diff --git a/dev-lang/execline/execline-2.8.3.0.ebuild b/dev-lang/execline/execline-2.8.3.0.ebuild
new file mode 100644
index 000000000000..56871cf7cedf
--- /dev/null
+++ b/dev-lang/execline/execline-2.8.3.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A non-interactive scripting language"
+HOMEPAGE="https://www.skarnet.org/software/execline/"
+SRC_URI="https://www.skarnet.org/software/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="static static-libs"
+
+REQUIRED_USE="static? ( static-libs )"
+
+RDEPEND=">=dev-libs/skalibs-2.11.2.0:=[static-libs?]"
+DEPEND="${RDEPEND}"
+
+HTML_DOCS=( doc/. )
+
+src_prepare() {
+ default
+
+ # Avoid QA warning for LDFLAGS addition
+ sed -i -e 's/.*-Wl,--hash-style=both$/:/' configure || die
+
+ sed -i -e '/AR := /d' -e '/RANLIB := /d' Makefile || die
+}
+
+src_configure() {
+ tc-export AR CC RANLIB
+
+ local myconf=(
+ --bindir=/bin
+ --dynlibdir=/usr/$(get_libdir)
+ --libdir=/usr/$(get_libdir)/${PN}
+ --with-dynlib=/usr/$(get_libdir)
+ --with-lib=/usr/$(get_libdir)/skalibs
+ --with-sysdeps=/usr/$(get_libdir)/skalibs
+ --enable-shared
+ $(use_enable static allstatic)
+ $(use_enable static static-libc)
+ $(use_enable static-libs static)
+ )
+
+ econf "${myconf[@]}"
+}