summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-03-02 17:23:55 +0100
committerAlfredo Tupone <tupone@gentoo.org>2024-03-02 17:24:29 +0100
commitfd3ee0d887453c5e16eb426116ab9c510c796ed8 (patch)
tree6008c2cd855d5d66a9d7d683791d4028eba59d0a /dev-lang/gnat-gpl
parentxfce-base/libxfce4util: Remove old (diff)
downloadgentoo-fd3ee0d887453c5e16eb426116ab9c510c796ed8.tar.gz
gentoo-fd3ee0d887453c5e16eb426116ab9c510c796ed8.tar.bz2
gentoo-fd3ee0d887453c5e16eb426116ab9c510c796ed8.zip
dev-lang/gnat-gpl: add check for clang
Closes: https://bugs.gentoo.org/883587 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-lang/gnat-gpl')
-rw-r--r--dev-lang/gnat-gpl/gnat-gpl-2021-r4.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-lang/gnat-gpl/gnat-gpl-2021-r4.ebuild b/dev-lang/gnat-gpl/gnat-gpl-2021-r4.ebuild
index c90d5ac44036..002368b2c0c0 100644
--- a/dev-lang/gnat-gpl/gnat-gpl-2021-r4.ebuild
+++ b/dev-lang/gnat-gpl/gnat-gpl-2021-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -50,6 +50,13 @@ BDEPEND=sys-devel/binutils
S="${WORKDIR}"/${MYP}
+pkg_pretend() {
+ toolchain_pkg_pretend
+ if tc-is-clang; then
+ die "${P} does not build with clang. It is bootstrapped."
+ fi
+}
+
src_prepare() {
if use amd64; then
BTSTRP=${BTSTRP_AMD64}