summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Parborg <darkdefende@gmail.com>2022-09-29 11:46:10 +0200
committerSam James <sam@gentoo.org>2022-09-30 00:52:33 +0100
commit6f5f03d793825d23190f9530d7d0359199f2cc30 (patch)
tree3c17e046310500bffa6015a37b59af437866ab5e /dev-lang/ispc
parentprofiles/arch: invert USE=tcmalloc to masked-by-default (diff)
downloadgentoo-6f5f03d793825d23190f9530d7d0359199f2cc30.tar.gz
gentoo-6f5f03d793825d23190f9530d7d0359199f2cc30.tar.bz2
gentoo-6f5f03d793825d23190f9530d7d0359199f2cc30.zip
dev-lang/ispc: Update live ebuild llvm patch
Signed-off-by: Sebastian Parborg <darkdefende@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang/ispc')
-rw-r--r--dev-lang/ispc/files/ispc-9999-llvm.patch11
1 files changed, 7 insertions, 4 deletions
diff --git a/dev-lang/ispc/files/ispc-9999-llvm.patch b/dev-lang/ispc/files/ispc-9999-llvm.patch
index 7303ac0fd6e8..934d9eaf5a60 100644
--- a/dev-lang/ispc/files/ispc-9999-llvm.patch
+++ b/dev-lang/ispc/files/ispc-9999-llvm.patch
@@ -2,15 +2,18 @@ diff --git a/CMakeLists.txt b/CMakeLists.txt
index 13e66268..27ff8364 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -218,7 +218,7 @@ if (WASM_ENABLED)
+@@ -218,10 +218,7 @@ if (WASM_ENABLED)
list(APPEND ISPC_TARGETS wasm-i32x4)
endif()
-set(CLANG_LIBRARY_LIST clangFrontend clangDriver clangSerialization clangParse clangSema clangAnalysis clangAST clangBasic clangEdit clangLex)
+set(CLANG_LIBRARY_LIST clang clang-cpp)
+-if (${LLVM_VERSION_NUMBER} VERSION_GREATER_EQUAL "15.0.0")
+- list(APPEND CLANG_LIBRARY_LIST clangSupport)
+-endif()
set(LLVM_COMPONENTS engine ipo bitreader bitwriter instrumentation linker option frontendopenmp)
-
- if (X86_ENABLED)
+ if (${LLVM_VERSION_NUMBER} VERSION_GREATER_EQUAL "15.0.0")
+ # windowsdriver is a small library introduced in LLVM 15. While it's targeted at Windows only,
@@ -402,11 +402,8 @@ if (ISPC_USE_ASAN)
endif()
@@ -24,7 +27,7 @@ index 13e66268..27ff8364 100644
+target_link_libraries(${PROJECT_NAME} ${CLANG_LIBRARY_LIST})
# Link against LLVM libraries
- target_link_libraries(${PROJECT_NAME} ${LLVM_LIBRARY_LIST})
+ target_link_libraries(${PROJECT_NAME} ${LLVM_LIBRARY_LIST} ${CMAKE_DL_LIBS})
diff --git a/src/llvmutil.cpp b/src/llvmutil.cpp
index 06fab989..57a7130f 100644
--- a/src/llvmutil.cpp