summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2016-04-04 11:17:56 -0400
committerMichael Sterrett <mr_bones_@gentoo.org>2016-04-04 11:17:56 -0400
commitbbc32104e701c5a8c1686efd7a83adc54dfee777 (patch)
treee219b072855d21790a606eaaf4d60721ac088390 /dev-lang/nasm/nasm-2.12.01.ebuild
parentdev-java/glazedlists: Correct header. (diff)
downloadgentoo-bbc32104e701c5a8c1686efd7a83adc54dfee777.tar.gz
gentoo-bbc32104e701c5a8c1686efd7a83adc54dfee777.tar.bz2
gentoo-bbc32104e701c5a8c1686efd7a83adc54dfee777.zip
dev-lang/nasm: version bump
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-lang/nasm/nasm-2.12.01.ebuild')
-rw-r--r--dev-lang/nasm/nasm-2.12.01.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-lang/nasm/nasm-2.12.01.ebuild b/dev-lang/nasm/nasm-2.12.01.ebuild
new file mode 100644
index 000000000000..e69def9404df
--- /dev/null
+++ b/dev-lang/nasm/nasm-2.12.01.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit flag-o-matic
+
+DESCRIPTION="groovy little assembler"
+HOMEPAGE="http://www.nasm.us/"
+SRC_URI="http://www.nasm.us/pub/nasm/releasebuilds/${PV/_}/${P/_}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="doc"
+
+DEPEND="dev-lang/perl
+ doc? ( app-text/ghostscript-gpl sys-apps/texinfo )"
+RDEPEND=""
+
+S=${WORKDIR}/${P/_}
+
+src_configure() {
+ strip-flags
+ econf
+}
+
+src_compile() {
+ emake nasmlib.o
+ emake all
+ use doc && emake doc
+}
+
+src_install() {
+ emake INSTALLROOT="${D}" install install_rdf
+ dodoc AUTHORS CHANGES ChangeLog README TODO
+ if use doc ; then
+ doinfo doc/info/*
+ dohtml doc/html/*
+ dodoc doc/nasmdoc.*
+ fi
+}