summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-lang/orc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-lang/orc')
-rw-r--r--dev-lang/orc/Manifest2
-rw-r--r--dev-lang/orc/metadata.xml5
-rw-r--r--dev-lang/orc/orc-0.4.23.ebuild39
-rw-r--r--dev-lang/orc/orc-0.4.24.ebuild55
4 files changed, 101 insertions, 0 deletions
diff --git a/dev-lang/orc/Manifest b/dev-lang/orc/Manifest
new file mode 100644
index 000000000000..a486c2267f53
--- /dev/null
+++ b/dev-lang/orc/Manifest
@@ -0,0 +1,2 @@
+DIST orc-0.4.23.tar.xz 450076 SHA256 767eaebce2941737b43368225ec54598b3055ca78b4dc50c4092f5fcdc0bdfe7 SHA512 e12bca0dcc7230da825834f50b88ff531a6aed83a29ccc5b57e969adb1af7ceb2c1d4dd04cd248e38db92fded6edc809c7deba42cd1ddeacd62b0e922950d92e WHIRLPOOL 62df2cbc9943b7c7e625519d0f16bf1becbce78b26ccaebbc315ac43f2ceee689b6ad6632ce5e49123aa59d97ec73c3268a3fd6b81f94ca4dcf97de7a3a222e5
+DIST orc-0.4.24.tar.xz 455880 SHA256 338cd493b5247300149821c6312bdf7422a3593ae98691fc75d7e4fe727bd39b SHA512 f40f692873a4fa506379a1b9e3ed1d329ee42470fb0b083aec5f993c1b6f756e63b772dbf664ca3328531c2f9be141ca43ed79a49572c1f02d82f85aa4306216 WHIRLPOOL 2d41972933ede160a9b85f6ed2ee4aabefc51557f2f65d30f9c65b32e4fcc6e14b8bf55609859b5084997bdc875a1249114de31ec59d944e993fc9e2f0651bc1
diff --git a/dev-lang/orc/metadata.xml b/dev-lang/orc/metadata.xml
new file mode 100644
index 000000000000..9e260ceca3e3
--- /dev/null
+++ b/dev-lang/orc/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gstreamer</herd>
+</pkgmetadata>
diff --git a/dev-lang/orc/orc-0.4.23.ebuild b/dev-lang/orc/orc-0.4.23.ebuild
new file mode 100644
index 000000000000..3db1c06b3b4c
--- /dev/null
+++ b/dev-lang/orc/orc-0.4.23.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit autotools-multilib flag-o-matic gnome2-utils
+
+DESCRIPTION="The Oil Runtime Compiler, a just-in-time compiler for array operations"
+HOMEPAGE="http://gstreamer.freedesktop.org/"
+SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="BSD BSD-2"
+SLOT="0"
+KEYWORDS="amd64 arm hppa ppc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples static-libs"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+"
+
+src_prepare() {
+ if ! use examples; then
+ sed -e '/SUBDIRS/ s:examples::' \
+ -i Makefile.am Makefile.in || die
+ fi
+
+ gnome2_environment_reset #556160
+}
+
+src_configure() {
+ # any optimisation on PPC/Darwin yields in a complaint from the assembler
+ # Parameter error: r0 not allowed for parameter %lu (code as 0 not r0)
+ # the same for Intel/Darwin, although the error message there is different
+ # but along the same lines
+ [[ ${CHOST} == *-darwin* ]] && filter-flags -O*
+ autotools-multilib_src_configure
+}
diff --git a/dev-lang/orc/orc-0.4.24.ebuild b/dev-lang/orc/orc-0.4.24.ebuild
new file mode 100644
index 000000000000..b468c6b9b80f
--- /dev/null
+++ b/dev-lang/orc/orc-0.4.24.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+inherit autotools-multilib flag-o-matic gnome2-utils pax-utils
+
+DESCRIPTION="The Oil Runtime Compiler, a just-in-time compiler for array operations"
+HOMEPAGE="http://gstreamer.freedesktop.org/"
+SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="BSD BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples hardened static-libs"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ >=dev-util/gtk-doc-am-1.12
+"
+
+src_prepare() {
+ if ! use examples; then
+ sed -e '/SUBDIRS/ s:examples::' \
+ -i Makefile.am Makefile.in || die
+ fi
+
+ gnome2_environment_reset #556160
+}
+
+src_configure() {
+ # any optimisation on PPC/Darwin yields in a complaint from the assembler
+ # Parameter error: r0 not allowed for parameter %lu (code as 0 not r0)
+ # the same for Intel/Darwin, although the error message there is different
+ # but along the same lines
+ [[ ${CHOST} == *-darwin* ]] && filter-flags -O*
+ autotools-multilib_src_configure
+}
+
+src_install() {
+ autotools-multilib_src_install
+ if use hardened; then
+ pax-mark m usr/bin/orc-bugreport || die
+ pax-mark m usr/bin/orcc || die
+ pax-mark m usr/$(get_libdir)/liborc*.so* || die
+ fi
+}
+
+pkg_postinst() {
+ if use hardened; then
+ ewarn "Please run \"revdep-pax\" after installation".
+ ewarn "It's provided by sys-apps/elfix."
+ fi
+}