summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Joldasov <bratishkaerik@getgoogleoff.me>2023-12-12 20:35:44 +0600
committerFlorian Schmaus <flow@gentoo.org>2023-12-13 08:47:23 +0100
commitff13cba4edbd2a712f1d863b96fa549f74a9e91b (patch)
tree6d426fcc2c2f4e5cde93a967a895f5b34accb98f /dev-lang/zig
parentnet-p2p/bitcoin-core: fix build failure when USE="-daemon" (diff)
downloadgentoo-ff13cba4edbd2a712f1d863b96fa549f74a9e91b.tar.gz
gentoo-ff13cba4edbd2a712f1d863b96fa549f74a9e91b.tar.bz2
gentoo-ff13cba4edbd2a712f1d863b96fa549f74a9e91b.zip
dev-lang/zig: remove ".max_rss" fields initializers from build.zig in 9999
They are too high and cause errors like below: * https://www.github.com/ziglang/zig/issues/18263 Signed-off-by: Eric Joldasov <bratishkaerik@getgoogleoff.me> Closes: https://github.com/gentoo/gentoo/pull/34252 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-lang/zig')
-rw-r--r--dev-lang/zig/zig-9999.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-lang/zig/zig-9999.ebuild b/dev-lang/zig/zig-9999.ebuild
index 6e98f73a3af4..a29f09a3db19 100644
--- a/dev-lang/zig/zig-9999.ebuild
+++ b/dev-lang/zig/zig-9999.ebuild
@@ -148,6 +148,11 @@ src_configure() {
}
src_compile() {
+ # Remove "limit memory usage" flags, it's already verified by
+ # CHECKREQS_MEMORY and causes unneccessary errors. Upstream set them
+ # according to CI OOM failures, which are higher than during Gentoo build.
+ sed -i -e '/\.max_rss = .*,/d' build.zig || die
+
if ! use llvm; then
$(tc-getCC) -o bootstrap bootstrap.c || die "Zig's bootstrap.c compilation failed"
edob ./bootstrap