summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-29 10:25:24 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-29 11:11:01 +0100
commitd1c9c94d40fdb501c81856c26a8688e9fe06c995 (patch)
treeb741a1d77a6fa7ec1348f57ce470603a7c248e7f /dev-lang
parentsys-devel/gettext: Remove epunt-cxx.eclass (diff)
downloadgentoo-d1c9c94d40fdb501c81856c26a8688e9fe06c995.tar.gz
gentoo-d1c9c94d40fdb501c81856c26a8688e9fe06c995.tar.bz2
gentoo-d1c9c94d40fdb501c81856c26a8688e9fe06c995.zip
dev-lang/python: Redo 3.8.1 patchset
Rebase patchset on top of v3.8.1 and move hashlib patch inside. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/Manifest1
-rw-r--r--dev-lang/python/python-3.8.1.ebuild7
2 files changed, 4 insertions, 4 deletions
diff --git a/dev-lang/python/Manifest b/dev-lang/python/Manifest
index 1d5b6d2ea261..13e8b814b572 100644
--- a/dev-lang/python/Manifest
+++ b/dev-lang/python/Manifest
@@ -14,3 +14,4 @@ DIST python-gentoo-patches-3.5.4-0.tar.xz 11704 BLAKE2B 4a7d71feff18c7c8c109bed1
DIST python-gentoo-patches-3.6.8.tar.xz 11224 BLAKE2B 5fe38282bcf28df18e0bd37756c880ae191ea738dc92f1cf83f682cfdc52525b9c44287dc99191a73d75c90672ab501b56adf49515b35ff1fdee88c8dc07b175 SHA512 89e700663db25d6d78eee1d4bfdab686c5341a794062f3a63df3485ac0b58deb4b4885d24701f3ae138d06ca783be92e310e1100c6d633910c33732f3cb0d7df
DIST python-gentoo-patches-3.7.4-1.tar.xz 10100 BLAKE2B 63e8fada89b64b59ba083745626a1e8a07bec0cf93b7b6ab405c33a0f2932cbe497a331c52895a07f10434b230c438f27c9582efecdd57f3bad15d9aa604d157 SHA512 11b0e811a9890a1235c85426061b35f9964eba64cac0536f4c9e0498b1cc66eb005f14aed34eead735b43e91c2b5babced60e3310f5329231a1706871b95b547
DIST python-gentoo-patches-3.8.0.tar.xz 9788 BLAKE2B 9ca14fa49fbbd11412451dc6ce32f643cdffdc988c6b2b312593e2b87b85d09e95ada397aaafa548cdb5cf58be09d970d020ef6f20a3575108581fb4647b7bfa SHA512 946be0babc8c67586309b48bffb5ac0a2a354b3798fa7e23c641cc836ff310ab744d75308d1324e9ed54720bf9f4d0aba1f89fb454a98bf9b9fa9484210b6ca5
+DIST python-gentoo-patches-3.8.1.tar.xz 10148 BLAKE2B d0674de768611405120bcd2e80a553d9a3325e5dc8360eee3223f89acc97a9aff6260d2610ae16a85777463f5987d93cf3428d42adcdd46867eeaa67471e9941 SHA512 bc38012821c9773cc0821d9ef7dcb8170e97fe87161c8c99b7500323e6f1c6c224d11152ff394bea5af42bb879ef18e1b89d6a16e9ab06a2c3512b5e2381cb08
diff --git a/dev-lang/python/python-3.8.1.ebuild b/dev-lang/python/python-3.8.1.ebuild
index 936ee9391577..8e3933724f01 100644
--- a/dev-lang/python/python-3.8.1.ebuild
+++ b/dev-lang/python/python-3.8.1.ebuild
@@ -8,12 +8,12 @@ inherit autotools flag-o-matic pax-utils python-utils-r1 toolchain-funcs
MY_P="Python-${PV}"
PYVER=$(ver_cut 1-2)
-PATCHSET_VERSION="3.8.0"
+PATCHSET="python-gentoo-patches-3.8.1"
DESCRIPTION="An interpreted, interactive, object-oriented programming language"
HOMEPAGE="https://www.python.org/"
SRC_URI="https://www.python.org/ftp/python/${PV}/${MY_P}.tar.xz
- https://dev.gentoo.org/~mgorny/dist/python-gentoo-patches-${PATCHSET_VERSION}.tar.xz"
+ https://dev.gentoo.org/~mgorny/dist/python/${PATCHSET}.tar.xz"
S="${WORKDIR}/${MY_P}"
LICENSE="PSF-2"
@@ -64,8 +64,7 @@ src_prepare() {
rm -fr Modules/zlib || die
local PATCHES=(
- "${FILESDIR}/python-3.7.5-hashlib.patch"
- "${WORKDIR}/patches"
+ "${WORKDIR}/${PATCHSET}"
)
default