summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-05-24 21:55:23 +0200
committerSam James <sam@gentoo.org>2021-05-24 21:38:38 +0000
commit59d42a91c016480f85370bd84093a33f5c3cde2f (patch)
tree7e5de33dc164a9a001fdcdb0dd11a2970faae12e /dev-libs/boost
parentdev-util/boost-build: Fix for numpy include (diff)
downloadgentoo-59d42a91c016480f85370bd84093a33f5c3cde2f.tar.gz
gentoo-59d42a91c016480f85370bd84093a33f5c3cde2f.tar.bz2
gentoo-59d42a91c016480f85370bd84093a33f5c3cde2f.zip
dev-libs/boost: Fix for numpy include
Closes: https://bugs.gentoo.org/733830 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: David Seifert <soap@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/20971 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/boost')
-rw-r--r--dev-libs/boost/boost-1.76.0-r1.ebuild3
-rw-r--r--dev-libs/boost/files/boost-1.76-boost-numpy.patch23
2 files changed, 25 insertions, 1 deletions
diff --git a/dev-libs/boost/boost-1.76.0-r1.ebuild b/dev-libs/boost/boost-1.76.0-r1.ebuild
index d760d92ea5af..16bc039e2269 100644
--- a/dev-libs/boost/boost-1.76.0-r1.ebuild
+++ b/dev-libs/boost/boost-1.76.0-r1.ebuild
@@ -45,7 +45,7 @@ RDEPEND="
zlib? ( sys-libs/zlib:=[${MULTILIB_USEDEP}] )
zstd? ( app-arch/zstd:=[${MULTILIB_USEDEP}] )"
DEPEND="${RDEPEND}"
-BDEPEND=">=dev-util/boost-build-${MAJOR_V}-r1"
+BDEPEND=">=dev-util/boost-build-${MAJOR_V}-r2"
PATCHES=(
"${FILESDIR}"/${PN}-1.71.0-disable_icu_rpath.patch
@@ -54,6 +54,7 @@ PATCHES=(
# Boost.MPI's __init__.py doesn't work on Py3
"${FILESDIR}"/${PN}-1.73-boost-mpi-python-PEP-328.patch
"${FILESDIR}"/${PN}-1.74-CVE-2012-2677.patch
+ "${FILESDIR}"/${PN}-1.76-boost-numpy.patch
)
python_bindings_needed() {
diff --git a/dev-libs/boost/files/boost-1.76-boost-numpy.patch b/dev-libs/boost/files/boost-1.76-boost-numpy.patch
new file mode 100644
index 000000000000..d9af132039e4
--- /dev/null
+++ b/dev-libs/boost/files/boost-1.76-boost-numpy.patch
@@ -0,0 +1,23 @@
+From 0796305c863804a2b31610507c531da5c0408422 Mon Sep 17 00:00:00 2001
+From: Peter Dimov <pdimov@gmail.com>
+Date: Mon, 24 May 2021 22:14:55 +0300
+Subject: [PATCH] Use the /python//numpy target instead of [ numpy.include ]
+ (fixes #361)
+
+---
+ libs/python/build/Jamfile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/libs/python/build/Jamfile b/libs/python/build/Jamfile
+index dbc9fb203..03b69a25d 100644
+--- a/libs/python/build/Jamfile
++++ b/libs/python/build/Jamfile
+@@ -117,7 +117,7 @@ lib boost_numpy
+ <define>BOOST_NUMPY_SOURCE
+ [ cond [ python.numpy ] : <library>/python//python_for_extensions ]
+ [ unless [ python.numpy ] : <build>no ]
+- <include>$(numpy-include)
++ <library>/python//numpy
+ <library>boost_python
+ <python-debugging>on:<define>BOOST_DEBUG_PYTHON
+ -<tag>@$(BOOST_JAMROOT_MODULE)%$(BOOST_JAMROOT_MODULE).tag