summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-08-28 12:06:11 -0700
committerMatt Turner <mattst88@gentoo.org>2021-08-28 14:14:24 -0700
commitc2dbfe4ac6c9beda86f739795ee47e834be0f5bc (patch)
treee636c4efef09da117c6c2efa1ac6ba80895bdbd1 /dev-libs/gdl/gdl-3.40.0.ebuild
parentapp-text/iso-codes: Version bump to 4.7.0 (diff)
downloadgentoo-c2dbfe4ac6c9beda86f739795ee47e834be0f5bc.tar.gz
gentoo-c2dbfe4ac6c9beda86f739795ee47e834be0f5bc.tar.bz2
gentoo-c2dbfe4ac6c9beda86f739795ee47e834be0f5bc.zip
dev-libs/gdl: Version bump to 3.40.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs/gdl/gdl-3.40.0.ebuild')
-rw-r--r--dev-libs/gdl/gdl-3.40.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-libs/gdl/gdl-3.40.0.ebuild b/dev-libs/gdl/gdl-3.40.0.ebuild
new file mode 100644
index 000000000000..2761698684bc
--- /dev/null
+++ b/dev-libs/gdl/gdl-3.40.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome2
+
+DESCRIPTION="GNOME docking library"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gdl"
+
+LICENSE="LGPL-2.1+"
+SLOT="3/5" # subslot = libgdl-3 soname version
+IUSE="+introspection"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-libs/glib:2
+ >=x11-libs/gtk+-3.0.0:3[introspection?]
+ >=dev-libs/libxml2-2.4:2
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.4
+"
+BDEPEND="
+ >=dev-util/intltool-0.40.4
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ --disable-gtk-doc
+}