summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-10-24 12:18:21 -0400
committerMike Frysinger <vapier@gentoo.org>2015-10-24 12:18:36 -0400
commite95251b4046a598d0b4b8520d54e05f5beded570 (patch)
treeb92e727e33fd23b7b06e2f3c8f53dda7379e3359 /dev-libs/gmp
parentdev-libs/ppl: mark 1.1 arm64/ia64/m68k/s390/sh stable #562068 (diff)
downloadgentoo-e95251b4046a598d0b4b8520d54e05f5beded570.tar.gz
gentoo-e95251b4046a598d0b4b8520d54e05f5beded570.tar.bz2
gentoo-e95251b4046a598d0b4b8520d54e05f5beded570.zip
dev-libs/gmp: add multilib logic to older SLOT #563886
Diffstat (limited to 'dev-libs/gmp')
-rw-r--r--dev-libs/gmp/gmp-4.3.2-r1.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/dev-libs/gmp/gmp-4.3.2-r1.ebuild b/dev-libs/gmp/gmp-4.3.2-r1.ebuild
index 94a25632690c..49e2f0c1534e 100644
--- a/dev-libs/gmp/gmp-4.3.2-r1.ebuild
+++ b/dev-libs/gmp/gmp-4.3.2-r1.ebuild
@@ -4,9 +4,9 @@
# this ebuild is only for the libgmp.so.3 ABI SONAME
-EAPI="3"
+EAPI="5"
-inherit eutils libtool toolchain-funcs
+inherit eutils libtool toolchain-funcs multilib-minimal
DESCRIPTION="Library for arithmetic on arbitrary precision integers, rational numbers, and floating-point numbers"
HOMEPAGE="http://gmplib.org/"
@@ -37,7 +37,7 @@ src_prepare() {
chmod a+rx configure
}
-src_configure() {
+multilib_src_configure() {
# Because of our 32-bit userland, 1.0 is the only HPPA ABI that works
# http://gmplib.org/manual/ABI-and-ISA.html#ABI-and-ISA (bug #344613)
if [[ ${CHOST} == hppa2.0-* ]] ; then
@@ -53,7 +53,7 @@ src_configure() {
export GMPABI
tc-export CC
- econf \
+ ECONF_SOURCE="${S}" econf \
--localstatedir=/var/state/gmp \
--disable-mpfr \
--disable-mpbsd \
@@ -61,7 +61,7 @@ src_configure() {
--disable-cxx
}
-src_install() {
- emake install-libLTLIBRARIES DESTDIR="${D}" || die
+multilib_src_install() {
+ emake DESTDIR="${D}" install-libLTLIBRARIES
rm "${D}"/usr/*/libgmp.{la,so} || die
}