summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-07-23 19:10:27 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-07-23 19:10:48 +0200
commit529ac465f12bf9ead54425ac142154d86389ae2a (patch)
tree84b9ae2861e4a08c979904ff097b606c9c6a8018 /dev-libs/hiredis
parentxfce-extra/xfce4-whiskermenu-plugin: Bump to 2.4.6 (diff)
downloadgentoo-529ac465f12bf9ead54425ac142154d86389ae2a.tar.gz
gentoo-529ac465f12bf9ead54425ac142154d86389ae2a.tar.bz2
gentoo-529ac465f12bf9ead54425ac142154d86389ae2a.zip
dev-libs/hiredis: don't call AR directly
While here, update other vars we pass to Makefile. Closes: https://bugs.gentoo.org/723704 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-libs/hiredis')
-rw-r--r--dev-libs/hiredis/files/hiredis-0.14.1-honor-AR.patch11
-rw-r--r--dev-libs/hiredis/hiredis-0.14.1.ebuild10
2 files changed, 17 insertions, 4 deletions
diff --git a/dev-libs/hiredis/files/hiredis-0.14.1-honor-AR.patch b/dev-libs/hiredis/files/hiredis-0.14.1-honor-AR.patch
new file mode 100644
index 000000000000..0bfcf0988e81
--- /dev/null
+++ b/dev-libs/hiredis/files/hiredis-0.14.1-honor-AR.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -51,7 +51,7 @@ DYLIB_MAJOR_NAME=$(LIBNAME).$(DYLIBSUFFIX).$(HIREDIS_MAJOR)
+ DYLIBNAME=$(LIBNAME).$(DYLIBSUFFIX)
+ DYLIB_MAKE_CMD=$(CC) -shared -Wl,-soname,$(DYLIB_MINOR_NAME) -o $(DYLIBNAME) $(LDFLAGS)
+ STLIBNAME=$(LIBNAME).$(STLIBSUFFIX)
+-STLIB_MAKE_CMD=ar rcs $(STLIBNAME)
++STLIB_MAKE_CMD=$(AR) rcs $(STLIBNAME)
+
+ # Platform-specific overrides
+ uname_S := $(shell sh -c 'uname -s 2>/dev/null || echo not')
diff --git a/dev-libs/hiredis/hiredis-0.14.1.ebuild b/dev-libs/hiredis/hiredis-0.14.1.ebuild
index 9028b420d2de..b0bf2fbfaedb 100644
--- a/dev-libs/hiredis/hiredis-0.14.1.ebuild
+++ b/dev-libs/hiredis/hiredis-0.14.1.ebuild
@@ -18,7 +18,10 @@ RESTRICT="!test? ( test )"
DEPEND="test? ( dev-db/redis )"
src_prepare() {
- local PATCHES=( "${FILESDIR}/${PN}-0.13.3-disable-network-tests.patch" )
+ local PATCHES=(
+ "${FILESDIR}"/${PN}-0.13.3-disable-network-tests.patch
+ "${FILESDIR}"/${PN}-0.14.1-honor-AR.patch
+ )
default
# use GNU ld syntax on Solaris
@@ -31,9 +34,8 @@ _build() {
CC="$(tc-getCC)" \
PREFIX="${EPREFIX}/usr" \
LIBRARY_PATH="$(get_libdir)" \
- ARCH= \
- DEBUG= \
- OPTIMIZATION="${CPPFLAGS}" \
+ DEBUG_FLAGS= \
+ OPTIMIZATION= \
"$@"
}