summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/injeqt
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/injeqt')
-rw-r--r--dev-libs/injeqt/Manifest1
-rw-r--r--dev-libs/injeqt/injeqt-1.0.0.ebuild31
-rw-r--r--dev-libs/injeqt/metadata.xml11
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-libs/injeqt/Manifest b/dev-libs/injeqt/Manifest
new file mode 100644
index 000000000000..d99797d8d9f8
--- /dev/null
+++ b/dev-libs/injeqt/Manifest
@@ -0,0 +1 @@
+DIST injeqt-1.0.0.tar.gz 63685 SHA256 ae53ac3453803fa0191e93368095029f2eeb35c01e8400d31787e7fe03afee18 SHA512 d5576e07a717085e108ff50ddc45ab26b540110e5753fd573504ed2c93538d947d1d8f2ad256f1ca9dd5d644949ce2528b66214f907229aee47bf7f6944776dc WHIRLPOOL ce17a4c28116e0b5bb4820d7bf6247925ea8e4241f52d4fc81ae8e95ecf4eb52a893e2594e4fcfd962de8c2f4b056dae68e844d6de89a41f4d945cf2373c5fcb
diff --git a/dev-libs/injeqt/injeqt-1.0.0.ebuild b/dev-libs/injeqt/injeqt-1.0.0.ebuild
new file mode 100644
index 000000000000..9b8404c8d05b
--- /dev/null
+++ b/dev-libs/injeqt/injeqt-1.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Dependency injection framework for Qt5"
+HOMEPAGE="https://github.com/vogel/injeqt"
+SRC_URI="https://github.com/vogel/injeqt/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-qt/qtcore-5.4.2:5
+"
+DEPEND="${RDEPEND}
+ test? ( >=dev-qt/qttest-5.4.2:5 )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_EXAMPLES=ON
+ $(cmake-utils_use_disable test TESTS)
+ )
+ cmake-utils_src_configure
+}
diff --git a/dev-libs/injeqt/metadata.xml b/dev-libs/injeqt/metadata.xml
new file mode 100644
index 000000000000..8b57291fe2a9
--- /dev/null
+++ b/dev-libs/injeqt/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>reavertm@gentoo.org</email>
+ <name>Maciej Mrozowski</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">vogel/injeqt</remote-id>
+ </upstream>
+</pkgmetadata>