summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-02-13 16:49:23 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2020-02-13 16:54:21 -0600
commit9d90eafd2071daa42a90a5317c7a624874bf36fc (patch)
treeade9a04b7bc9f7eb36d2c5999b92f176c9d06c5a /dev-libs/leatherman/leatherman-1.8.0.ebuild
parentdev-libs/leatherman: 1.10.0 stable amd64 and x86 (diff)
downloadgentoo-9d90eafd2071daa42a90a5317c7a624874bf36fc.tar.gz
gentoo-9d90eafd2071daa42a90a5317c7a624874bf36fc.tar.bz2
gentoo-9d90eafd2071daa42a90a5317c7a624874bf36fc.zip
dev-libs/leatherman: cleanup
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-libs/leatherman/leatherman-1.8.0.ebuild')
-rw-r--r--dev-libs/leatherman/leatherman-1.8.0.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/dev-libs/leatherman/leatherman-1.8.0.ebuild b/dev-libs/leatherman/leatherman-1.8.0.ebuild
deleted file mode 100644
index 8e26f01f7bc5..000000000000
--- a/dev-libs/leatherman/leatherman-1.8.0.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils multilib
-
-DESCRIPTION="A C++ toolkit"
-HOMEPAGE="https://github.com/puppetlabs/leatherman"
-SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-IUSE="debug static-libs test"
-RESTRICT="!test? ( test )"
-KEYWORDS="amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc x86"
-SLOT="0/${PV}"
-
-RDEPEND="net-misc/curl"
-DEPEND=">=dev-libs/boost-1.54:=[nls]
- net-misc/curl
- >=sys-devel/gcc-4.8:*"
-
-PATCHES=( "${FILESDIR}"/portage-sandbox-test-fix.patch )
-
-src_prepare() {
- sed -i 's/\-Werror\ //g' "cmake/cflags.cmake" || die
- cmake-utils_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DCMAKE_VERBOSE_MAKEFILE=ON
- -DCMAKE_BUILD_TYPE=None
- )
- if ! use static-libs; then
- mycmakeargs+=(
- -DLEATHERMAN_SHARED=ON
- )
- else
- mycmakeargs+=(
- -DLEATHERMAN_SHARED=OFF
- )
- fi
- if use debug; then
- mycmakeargs+=(
- -DCMAKE_BUILD_TYPE=Debug
- )
- fi
- cmake-utils_src_configure
-}
-
-src_test() {
- "${WORKDIR}/${P}"_build/bin/leatherman_test
-}
-
-src_install() {
- cmake-utils_src_install
-}