summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2023-12-24 12:53:35 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2023-12-24 12:56:37 -0600
commit7e6e580056ce752300be61a18f403d7bf30a5590 (patch)
treeeba73c9f64d44cca8cc2e35e6c9587b733d1a941 /dev-libs/leatherman
parentmedia-fonts/lxgw-wenkai: add 1.315 (diff)
downloadgentoo-7e6e580056ce752300be61a18f403d7bf30a5590.tar.gz
gentoo-7e6e580056ce752300be61a18f403d7bf30a5590.tar.bz2
gentoo-7e6e580056ce752300be61a18f403d7bf30a5590.zip
dev-libs/leatherman: drop 1.12.9
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-libs/leatherman')
-rw-r--r--dev-libs/leatherman/Manifest1
-rw-r--r--dev-libs/leatherman/leatherman-1.12.9.ebuild56
2 files changed, 0 insertions, 57 deletions
diff --git a/dev-libs/leatherman/Manifest b/dev-libs/leatherman/Manifest
index c9a91fbc18c8..5f847fe81993 100644
--- a/dev-libs/leatherman/Manifest
+++ b/dev-libs/leatherman/Manifest
@@ -1,2 +1 @@
DIST leatherman-1.12.11.tar.gz 816707 BLAKE2B 7e94c24b541efb9a8f879897eb13cbb7fbce7e87fd7543625e0c88717a79ccdcd1bc8d06268582ee4445a2628a71ef6ffd64b38f93ad0fbdd811e686623ac4f6 SHA512 26fb96a2f8bb34efe4df1220db18f9816ecd3b34d3ef1e84ecfda8833318f7e4f3dcd93535034669110e62fa69bbf9c43599d84739321c6d0075475cd2de7671
-DIST leatherman-1.12.9.tar.gz 816107 BLAKE2B 1c2e50767585a30da40fdacde0aa8655cefc2a41cadd24a7689be5da0afcbe8627293d37780442873907996f01401b46340a3d7be5d9b2a65b2f87191daca6c3 SHA512 e69f2b0c04a1cbd20e097abcc020e7b27fb74f168207fcbcffce9fd0edd1760acc75d5c5f645d3a798f106e129ce73e512f0c11699733475b290dfc876de0565
diff --git a/dev-libs/leatherman/leatherman-1.12.9.ebuild b/dev-libs/leatherman/leatherman-1.12.9.ebuild
deleted file mode 100644
index 8466060b3186..000000000000
--- a/dev-libs/leatherman/leatherman-1.12.9.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="A C++ toolkit"
-HOMEPAGE="https://github.com/puppetlabs/leatherman"
-SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0/${PV}"
-KEYWORDS="amd64 ~arm ~arm64 ~hppa ppc ppc64 ~riscv sparc x86"
-IUSE="debug static-libs test"
-#RESTRICT="!test? ( test )"
-RESTRICT="test" # restricted til we don't need the shared_nowide patch
-
-RDEPEND="dev-libs/boost:=[nls]
- net-misc/curl"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/portage-sandbox-test-fix.patch
- "${FILESDIR}"/1.12.2-shared_nowide.patch
-)
-
-src_prepare() {
- sed -i 's/\-Werror\ //g' "cmake/cflags.cmake" || die
- # vendored boost lib conflicts with boost 1.73 and above
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- -DCMAKE_VERBOSE_MAKEFILE=ON
- -DCMAKE_BUILD_TYPE=None
- -DLEATHERMAN_ENABLE_TESTING=$(usex test)
- # We depend on Boost with nls, so this is always true
- -DLEATHERMAN_USE_ICU=ON
-
- -DLEATHERMAN_SHARED=$(usex !static-libs)
- )
-
- if use debug; then
- mycmakeargs+=(
- -DCMAKE_BUILD_TYPE=Debug
- )
- fi
-
- cmake_src_configure
-}
-
-src_test() {
- "${WORKDIR}/${P}"_build/bin/leatherman_test || die
-}