summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2017-09-03 08:03:01 +0300
committerMart Raudsepp <leio@gentoo.org>2017-09-03 08:03:01 +0300
commit302644a8cc563d108de86ca849e00c1541dee2d5 (patch)
tree840baa59ab54cc131f395304b0c834ee6659bf7c /dev-libs/libgdata/libgdata-0.17.8.ebuild
parentapp-arch/torrentzip: use HTTPS protocol for dev.gentoo.org links (diff)
downloadgentoo-302644a8cc563d108de86ca849e00c1541dee2d5.tar.gz
gentoo-302644a8cc563d108de86ca849e00c1541dee2d5.tar.bz2
gentoo-302644a8cc563d108de86ca849e00c1541dee2d5.zip
Revert "dev-libs/libgdata: drop old revisions"
This reverts commit d2ad299798b58873b9f72ab57c4e15e9a226131c.
Diffstat (limited to 'dev-libs/libgdata/libgdata-0.17.8.ebuild')
-rw-r--r--dev-libs/libgdata/libgdata-0.17.8.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/dev-libs/libgdata/libgdata-0.17.8.ebuild b/dev-libs/libgdata/libgdata-0.17.8.ebuild
new file mode 100644
index 000000000000..7c6ac6bb7a98
--- /dev/null
+++ b/dev-libs/libgdata/libgdata-0.17.8.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala
+
+DESCRIPTION="GLib-based library for accessing online service APIs using the GData protocol"
+HOMEPAGE="https://wiki.gnome.org/Projects/libgdata"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/22" # subslot = libgdata soname version
+
+IUSE="+crypt gnome-online-accounts +introspection static-libs test vala"
+REQUIRED_USE="
+ gnome-online-accounts? ( crypt )
+ vala? ( introspection )
+"
+
+KEYWORDS="alpha amd64 ~arm ~arm64 hppa ~ia64 ~ppc ~ppc64 sparc x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.38.0:2
+ >=dev-libs/json-glib-0.15
+ >=dev-libs/libxml2-2:2
+ >=net-libs/liboauth-0.9.4
+ >=net-libs/libsoup-2.55.90:2.4[introspection?]
+ >=x11-libs/gdk-pixbuf-2.14:2
+ crypt? ( app-crypt/gcr:= )
+ gnome-online-accounts? ( >=net-libs/gnome-online-accounts-3.8:= )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.7:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.25
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+ test? ( >=net-libs/uhttpmock-0.5 )
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # configure checks for gtk:3, but only uses it for demos which are not installed
+ gnome2_src_configure \
+ $(use_enable crypt gnome) \
+ $(use_enable gnome-online-accounts goa) \
+ $(use_enable introspection) \
+ $(use_enable vala) \
+ $(use_enable static-libs static) \
+ $(use_enable test always-build-tests) \
+ GTK_CFLAGS= \
+ GTK_LIBS=
+}
+
+src_test() {
+ unset ORBIT_SOCKETDIR
+ export GSETTINGS_BACKEND="memory" #486412
+ dbus-launch emake check
+}