summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-20 23:09:49 +0100
committerSam James <sam@gentoo.org>2022-06-20 23:10:31 +0100
commitb906bc7969ffc1adbaa018bebfe51301f3a7f579 (patch)
treecb535ef293929214d2b6301b28e82f9441b46ae5 /dev-libs/libmaa
parentdev-libs/link-grammar: Version bump to 5.10.5 (diff)
downloadgentoo-b906bc7969ffc1adbaa018bebfe51301f3a7f579.tar.gz
gentoo-b906bc7969ffc1adbaa018bebfe51301f3a7f579.tar.bz2
gentoo-b906bc7969ffc1adbaa018bebfe51301f3a7f579.zip
dev-libs/libmaa: actually add revbump using slibtool patch
I went to turn the PR into a revbump but didn't git add the final ebuild, apparently. Bug: https://bugs.gentoo.org/778464 Closes: https://github.com/gentoo/gentoo/pull/25995 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libmaa')
-rw-r--r--dev-libs/libmaa/libmaa-1.3.2-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-libs/libmaa/libmaa-1.3.2-r1.ebuild b/dev-libs/libmaa/libmaa-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..f19e9a392a5e
--- /dev/null
+++ b/dev-libs/libmaa/libmaa-1.3.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Library with low-level data structures which are helpful for writing compilers"
+HOMEPAGE="http://www.dict.org/"
+SRC_URI="mirror://sourceforge/dict/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-libtool.patch # 778464
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_install() {
+ default
+ dodoc doc/libmaa.600dpi.ps
+
+ # don't want static or libtool archives, #401935
+ find "${D}" \( -name '*.a' -o -name '*.la' \) -delete || die
+}