summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-03-07 08:45:06 +0100
committerJeroen Roovers <jer@gentoo.org>2017-03-07 08:45:24 +0100
commitbbc294f73ee398ac7367e432e96293741a2ceb4d (patch)
treec8b26d47c09d9eb66a342506cda01434cd9b39a5 /dev-libs/libnl
parentapp-editors/vile: version bump to 9.8s (diff)
downloadgentoo-bbc294f73ee398ac7367e432e96293741a2ceb4d.tar.gz
gentoo-bbc294f73ee398ac7367e432e96293741a2ceb4d.tar.bz2
gentoo-bbc294f73ee398ac7367e432e96293741a2ceb4d.zip
dev-libs/libnl: Version bump.
Package-Manager: Portage-2.3.4, Repoman-2.3.1
Diffstat (limited to 'dev-libs/libnl')
-rw-r--r--dev-libs/libnl/Manifest1
-rw-r--r--dev-libs/libnl/libnl-3.3.0_rc1.ebuild106
-rw-r--r--dev-libs/libnl/libnl-3.3.9999.ebuild (renamed from dev-libs/libnl/libnl-3.2.9999.ebuild)0
3 files changed, 107 insertions, 0 deletions
diff --git a/dev-libs/libnl/Manifest b/dev-libs/libnl/Manifest
index bb8cfd19afd4..c911dab5b46d 100644
--- a/dev-libs/libnl/Manifest
+++ b/dev-libs/libnl/Manifest
@@ -2,3 +2,4 @@ DIST libnl-1.1.4.tar.gz 1174974 SHA256 4f80c21fe5bbcdde6e72b59b4f98306063a41421f
DIST libnl-3.2.28-in6.patch.xz 6368 SHA256 0cbb8dc4e3cdc90a4a0608a26af1971d7c1c397bb5f089de8c8d640e57b7b631 SHA512 de14f7540e514871db2058236a339192443423e56f2f5bd52e02ff06873c9e411029b12f3119e57eb01201ce3643ce78ca3e8d9ada4f6ba318df96288304bead WHIRLPOOL 1f1ebfc06a0cf516202cee3aaee92d7ed584ec9633d48c23e666d40bf48d658cc27a00c9f8881a7e976e21fc66fb867e10cadd8a6c0c8826ff4fab712cb20f3d
DIST libnl-3.2.28.tar.gz 941954 SHA256 cd608992c656e8f6e3ab6c1391b162a5a51c49336b9219f7f390e61fc5437c41 SHA512 b5f145ecafb2625ed1c42594afd6063f112a601077de5c35884b3c3bc8c562b29b52a006ccebd795c127fe69692a82def425c8605afed7e6d441582943e803d9 WHIRLPOOL ff49346ddc31105a300ebffc0e4d4956ac85ade5e92e884c62e696d7d4234d40e63cf4839e6b6fd2d98d2122662d36d3f41666391686a83c8bf966e53e22ed25
DIST libnl-3.2.29.tar.gz 963681 SHA256 0beb593dc6abfffa18a5c787b27884979c1b7e7f1fd468c801e3cc938a685922 SHA512 45e22b02368c479e01db7160345a0d3c73abf345e7b49bf350811243a17f307f5c6c3df639ec1e0c456707578aca8d69aad8afa697ac21449f521a3e39712670 WHIRLPOOL 1273dcaee79ecfdca947110c5e7ff70947703b1b0fda43fdb7c74edd78c6938f675e9a586aaff8feefce56a1f3137cbc50d3626ac336e6afa2ca8cbd8627e6eb
+DIST libnl-3.3.0-rc1.tar.gz 933271 SHA256 426f69373191760174cb40cb1f9a811248a56f8962fe66cf22156a71685fd110 SHA512 8084a54efac0256f6badd438fb79512cc53ee5f6635c4f301d1f7b3cfdf326387176949ac368903109dda02f55589ed09cb8f3218ebac973457c6f2740951488 WHIRLPOOL b8db1d4f589d32f0da830dc934765c67087665ac58366265fc2f5d649178c161cfc41e2faf139859c9547c5b20f28bfff5875db9c51cbfe93df3ecc01c3d7f3e
diff --git a/dev-libs/libnl/libnl-3.3.0_rc1.ebuild b/dev-libs/libnl/libnl-3.3.0_rc1.ebuild
new file mode 100644
index 000000000000..64aedbef471b
--- /dev/null
+++ b/dev-libs/libnl/libnl-3.3.0_rc1.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+DISTUTILS_OPTIONAL=1
+inherit distutils-r1 eutils libtool multilib multilib-minimal
+
+LIBNL_P=${P/_/-}
+LIBNL_DIR=${PV/_/}
+LIBNL_DIR=${LIBNL_DIR//./_}
+
+DESCRIPTION="Libraries providing APIs to netlink protocol based Linux kernel interfaces"
+HOMEPAGE="http://www.infradead.org/~tgr/libnl/ https://github.com/thom311/libnl"
+SRC_URI="
+ https://github.com/thom311/${PN}/releases/download/${PN}${LIBNL_DIR}/${P/_rc/-rc}.tar.gz
+"
+LICENSE="LGPL-2.1 utils? ( GPL-2 )"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs python utils"
+
+RDEPEND="
+ python? ( ${PYTHON_DEPS} )
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-baselibs-20140508-r5
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ python? ( dev-lang/swig )
+ sys-devel/bison
+ sys-devel/flex
+"
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+DOCS=(
+ ChangeLog
+)
+
+S=${WORKDIR}/${LIBNL_P}
+
+MULTILIB_WRAPPED_HEADERS=(
+ # we do not install CLI stuff for non-native
+ /usr/include/libnl3/netlink/cli/addr.h
+ /usr/include/libnl3/netlink/cli/class.h
+ /usr/include/libnl3/netlink/cli/cls.h
+ /usr/include/libnl3/netlink/cli/ct.h
+ /usr/include/libnl3/netlink/cli/exp.h
+ /usr/include/libnl3/netlink/cli/link.h
+ /usr/include/libnl3/netlink/cli/neigh.h
+ /usr/include/libnl3/netlink/cli/qdisc.h
+ /usr/include/libnl3/netlink/cli/route.h
+ /usr/include/libnl3/netlink/cli/rule.h
+ /usr/include/libnl3/netlink/cli/tc.h
+ /usr/include/libnl3/netlink/cli/utils.h
+)
+
+src_prepare() {
+ default
+
+ elibtoolize
+
+ if use python; then
+ cd "${S}"/python || die
+ distutils-r1_src_prepare
+ fi
+
+ # out-of-source build broken
+ # https://github.com/thom311/libnl/pull/58
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ econf \
+ --disable-silent-rules \
+ $(use_enable static-libs static) \
+ $(multilib_native_use_enable utils cli)
+}
+
+multilib_src_compile() {
+ default
+
+ if multilib_is_native_abi && use python; then
+ cd python || die
+ distutils-r1_src_compile
+ fi
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+
+ if multilib_is_native_abi && use python; then
+ # Unset DOCS= since distutils-r1.eclass interferes
+ local DOCS=()
+ cd python || die
+ distutils-r1_src_install
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files --modules
+}
diff --git a/dev-libs/libnl/libnl-3.2.9999.ebuild b/dev-libs/libnl/libnl-3.3.9999.ebuild
index f65e3012a6a4..f65e3012a6a4 100644
--- a/dev-libs/libnl/libnl-3.2.9999.ebuild
+++ b/dev-libs/libnl/libnl-3.3.9999.ebuild