summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2018-12-19 18:33:42 -0500
committerAnthony G. Basile <blueness@gentoo.org>2018-12-19 18:35:13 -0500
commitf2899d7304f5bf799ea31a2eab7a41db5ebf2d24 (patch)
treeb423495c49e7969ffda6ff5e712d9acc83335ba0 /dev-libs/libressl/libressl-2.8.3.ebuild
parentmedia-radio/js8call: bump (diff)
downloadgentoo-f2899d7304f5bf799ea31a2eab7a41db5ebf2d24.tar.gz
gentoo-f2899d7304f5bf799ea31a2eab7a41db5ebf2d24.tar.bz2
gentoo-f2899d7304f5bf799ea31a2eab7a41db5ebf2d24.zip
dev-libs/libressl: version bumps to 2.7.5, 2.8.3, and 2.9.0
Signed-off-by: Anthony G. Basile <blueness@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-libs/libressl/libressl-2.8.3.ebuild')
-rw-r--r--dev-libs/libressl/libressl-2.8.3.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-libs/libressl/libressl-2.8.3.ebuild b/dev-libs/libressl/libressl-2.8.3.ebuild
new file mode 100644
index 000000000000..4ca27fb26c11
--- /dev/null
+++ b/dev-libs/libressl/libressl-2.8.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib-minimal
+
+DESCRIPTION="Free version of the SSL/TLS protocol forked from OpenSSL"
+HOMEPAGE="https://www.libressl.org/"
+SRC_URI="https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${P}.tar.gz"
+
+LICENSE="ISC openssl"
+# Reflects ABI of libcrypto.so and libssl.so. Since these can differ,
+# we'll try to use the max of either. However, if either change between
+# versions, we have to change the subslot to trigger rebuild of consumers.
+SLOT="0/46"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+asm static-libs test"
+REQUIRED_USE="test? ( static-libs )"
+
+RDEPEND="!dev-libs/openssl:0"
+DEPEND="${RDEPEND}"
+PDEPEND="app-misc/ca-certificates"
+
+src_prepare() {
+ touch crypto/Makefile.in
+
+ sed -i \
+ -e '/^[ \t]*CFLAGS=/s#-g ##' \
+ -e '/^[ \t]*CFLAGS=/s#-g"#"#' \
+ -e '/^[ \t]*CFLAGS=/s#-O2 ##' \
+ -e '/^[ \t]*CFLAGS=/s#-O2"#"#' \
+ -e '/^[ \t]*USER_CFLAGS=/s#-O2 ##' \
+ -e '/^[ \t]*USER_CFLAGS=/s#-O2"#"#' \
+ configure || die "fixing CFLAGS failed"
+
+ eapply_user
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable asm) \
+ $(use_enable static-libs static)
+}
+
+multilib_src_test() {
+ emake check
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${D}" -name '*.la' -exec rm -f {} + || die
+}