summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2020-05-06 01:34:56 +0900
committerAkinori Hattori <hattya@gentoo.org>2020-05-06 01:35:49 +0900
commit5640fe7f3dd581cb33d57eda6b4eb932b201d15e (patch)
treee62032a4bf7d7da05a3c8f71cac5b38688dd85b4 /dev-libs/libutf8proc
parentdev-libs/libutf8proc: update DESCRIPTION (diff)
downloadgentoo-5640fe7f3dd581cb33d57eda6b4eb932b201d15e.tar.gz
gentoo-5640fe7f3dd581cb33d57eda6b4eb932b201d15e.tar.bz2
gentoo-5640fe7f3dd581cb33d57eda6b4eb932b201d15e.zip
dev-libs/libutf8proc: tidy
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'dev-libs/libutf8proc')
-rw-r--r--dev-libs/libutf8proc/libutf8proc-2.2.0_p1-r1.ebuild4
-rw-r--r--dev-libs/libutf8proc/libutf8proc-2.4.0.ebuild27
2 files changed, 14 insertions, 17 deletions
diff --git a/dev-libs/libutf8proc/libutf8proc-2.2.0_p1-r1.ebuild b/dev-libs/libutf8proc/libutf8proc-2.2.0_p1-r1.ebuild
index 0f94bc97db0e..17e995142ad2 100644
--- a/dev-libs/libutf8proc/libutf8proc-2.2.0_p1-r1.ebuild
+++ b/dev-libs/libutf8proc/libutf8proc-2.2.0_p1-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI="7"
inherit toolchain-funcs
@@ -23,7 +23,7 @@ S="${WORKDIR}/${MY_P}"
_emake() {
source "${EPREFIX}"/usr/share/netsurf-buildsystem/gentoo-helpers.sh
netsurf_define_makeconf
- emake "${NETSURF_MAKECONF[@]}" COMPONENT_TYPE=lib-shared $@
+ emake "${NETSURF_MAKECONF[@]}" COMPONENT_TYPE=lib-shared "${@}"
}
src_compile() {
diff --git a/dev-libs/libutf8proc/libutf8proc-2.4.0.ebuild b/dev-libs/libutf8proc/libutf8proc-2.4.0.ebuild
index 23ca084b62ad..65b7342ae30b 100644
--- a/dev-libs/libutf8proc/libutf8proc-2.4.0.ebuild
+++ b/dev-libs/libutf8proc/libutf8proc-2.4.0.ebuild
@@ -1,15 +1,13 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI="7"
inherit toolchain-funcs
-MY_P="${P#lib}"
-
DESCRIPTION="A clean C Library for processing UTF-8 Unicode data"
HOMEPAGE="https://github.com/JuliaStrings/utf8proc"
-SRC_URI="https://github.com/JuliaStrings/utf8proc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/JuliaStrings/${PN#lib}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0/${PV}"
@@ -17,10 +15,10 @@ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-cyg
IUSE="test"
RESTRICT="!test? ( test )"
-S="${WORKDIR}/${MY_P}"
-
BDEPEND="test? ( =app-i18n/unicode-data-12.0* )"
+S="${WORKDIR}/${P#lib}"
+
PATCHES=(
# Don't build or install static libs
"${FILESDIR}/${PN}-2.3.0-no-static.patch"
@@ -28,18 +26,17 @@ PATCHES=(
"${FILESDIR}/${PN}-2.3.0-tests-nofetch.patch"
)
-_emake() {
- emake CC=$(tc-getCC) AR=$(tc-getAR) "$@"
-}
-
src_compile() {
- _emake
+ emake \
+ AR="$(tc-getAR)" \
+ CC="$(tc-getCC)"
}
src_install() {
- _emake DESTDIR="${D}" \
- prefix="${EPREFIX}/usr" \
- libdir="${EPREFIX}/usr/$(get_libdir)" \
+ emake \
+ DESTDIR="${ED}" \
+ prefix="/usr" \
+ libdir="/usr/$(get_libdir)" \
install
# This package used to use netsurf's version as an upstream, which lives in
# its own little world. Unlike julia's version, it puts its header file
@@ -51,5 +48,5 @@ src_install() {
}
src_test() {
- _emake check
+ emake CC="$(tc-getCC)" check
}