summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-07-27 22:09:47 +0200
committerDavid Seifert <soap@gentoo.org>2022-07-27 22:09:47 +0200
commite2e3f1c2a41501a9552a3f81b4336dc370cb32cc (patch)
treef5bed8d1f408b19726b7115a5848b64b92b07739 /dev-libs/libx86
parentdev-libs/libtar: update EAPI 6 -> 8 (diff)
downloadgentoo-e2e3f1c2a41501a9552a3f81b4336dc370cb32cc.tar.gz
gentoo-e2e3f1c2a41501a9552a3f81b4336dc370cb32cc.tar.bz2
gentoo-e2e3f1c2a41501a9552a3f81b4336dc370cb32cc.zip
dev-libs/libx86: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-libs/libx86')
-rw-r--r--dev-libs/libx86/files/libx86-0.99-ifmask.patch4
-rw-r--r--dev-libs/libx86/files/libx86-1.1-makefile.patch4
-rw-r--r--dev-libs/libx86/files/libx86-1.1-x86emu.patch10
-rw-r--r--dev-libs/libx86/libx86-1.1-r4.ebuild50
-rw-r--r--dev-libs/libx86/libx86-1.1-r5.ebuild39
5 files changed, 47 insertions, 60 deletions
diff --git a/dev-libs/libx86/files/libx86-0.99-ifmask.patch b/dev-libs/libx86/files/libx86-0.99-ifmask.patch
index c99eeb819f72..2a6aaa6fbe47 100644
--- a/dev-libs/libx86/files/libx86-0.99-ifmask.patch
+++ b/dev-libs/libx86/files/libx86-0.99-ifmask.patch
@@ -1,5 +1,5 @@
---- lrmi.c.orig 2008-09-06 12:24:36.070136428 +0200
-+++ lrmi.c 2008-09-06 12:28:10.584287458 +0200
+--- a/lrmi.c
++++ b/lrmi.c
@@ -55,6 +55,18 @@ OTHER DEALINGS IN THE SOFTWARE.
#include "x86-common.h"
diff --git a/dev-libs/libx86/files/libx86-1.1-makefile.patch b/dev-libs/libx86/files/libx86-1.1-makefile.patch
index 471c3fbc78fd..4cea20c81a08 100644
--- a/dev-libs/libx86/files/libx86-1.1-makefile.patch
+++ b/dev-libs/libx86/files/libx86-1.1-makefile.patch
@@ -1,5 +1,5 @@
---- Makefile.orig 2013-02-11 16:35:56.834368910 +0400
-+++ Makefile 2013-02-11 16:36:02.587369368 +0400
+--- a/Makefile
++++ b/Makefile
@@ -22,7 +22,7 @@
$(AR) cru libx86.a $(OBJECTS)
diff --git a/dev-libs/libx86/files/libx86-1.1-x86emu.patch b/dev-libs/libx86/files/libx86-1.1-x86emu.patch
index 7b4fe428e1b3..685c7a9ff6de 100644
--- a/dev-libs/libx86/files/libx86-1.1-x86emu.patch
+++ b/dev-libs/libx86/files/libx86-1.1-x86emu.patch
@@ -1,6 +1,5 @@
-diff -Naur libx86-1.1+ds1.orig/Makefile libx86-1.1+ds1/Makefile
---- a/libx86-1.1/Makefile 2008-05-19 12:28:59.000000000 +0300
-+++ b/libx86-1.1/Makefile 2012-02-20 01:32:03.750068423 +0200
+--- a/Makefile
++++ b/Makefile
@@ -5,6 +5,7 @@
ifeq ($(BACKEND),x86emu)
OBJECTS += thunk.o x86emu/decode.o x86emu/debug.o x86emu/fpu.o \
@@ -9,9 +8,8 @@ diff -Naur libx86-1.1+ds1.orig/Makefile libx86-1.1+ds1/Makefile
else
OBJECTS += lrmi.o
endif
-diff -Naur libx86-1.1+ds1.orig/thunk.c libx86-1.1+ds1/thunk.c
---- a/libx86-1.1+ds1.orig/thunk.c 2008-04-03 03:48:00.000000000 +0300
-+++ b/libx86-1.1/thunk.c 2012-02-20 01:12:56.468820192 +0200
+--- a/thunk.c
++++ b/thunk.c
@@ -32,6 +32,7 @@
#define TRUE 1
#define FALSE 0
diff --git a/dev-libs/libx86/libx86-1.1-r4.ebuild b/dev-libs/libx86/libx86-1.1-r4.ebuild
deleted file mode 100644
index 350a47c4a088..000000000000
--- a/dev-libs/libx86/libx86-1.1-r4.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs flag-o-matic
-
-DESCRIPTION="A hardware-independent library for executing real-mode x86 code"
-HOMEPAGE="https://www.codon.org.uk/~mjg59/libx86/"
-SRC_URI="https://www.codon.org.uk/~mjg59/${PN}/downloads/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm -ppc -riscv -sparc x86"
-IUSE="static-libs"
-
-src_prepare() {
- # fix compile failure with linux-headers-2.6.26, bug 235599
- eapply -p0 "${FILESDIR}/${PN}-0.99-ifmask.patch"
- # Patch for bugs #236888 and #456648
- eapply -p0 "${FILESDIR}/${P}-makefile.patch"
- # Wider arch compatibility, bug #579682
- eapply -p2 "${FILESDIR}/${P}-x86emu.patch"
-
- eapply_user
-}
-
-src_configure() {
- tc-export CC AR
- append-flags -fno-delete-null-pointer-checks #523276
-}
-
-src_compile() {
- local ARGS
- use x86 || ARGS="BACKEND=x86emu"
- emake ${ARGS} LIBRARY=shared shared
- if use static-libs; then
- emake ${ARGS} objclean
- emake ${ARGS} LIBRARY=static static
- fi
-}
-
-src_install() {
- local install_static;
- use static-libs && install_static='install-static'
- emake \
- LIBDIR="/usr/$(get_libdir)" \
- DESTDIR="${D}" \
- install-header install-shared ${install_static}
-}
diff --git a/dev-libs/libx86/libx86-1.1-r5.ebuild b/dev-libs/libx86/libx86-1.1-r5.ebuild
new file mode 100644
index 000000000000..ac4aa8723d12
--- /dev/null
+++ b/dev-libs/libx86/libx86-1.1-r5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="A hardware-independent library for executing real-mode x86 code"
+HOMEPAGE="https://www.codon.org.uk/~mjg59/libx86/"
+SRC_URI="https://www.codon.org.uk/~mjg59/${PN}/downloads/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm -ppc -riscv -sparc x86"
+
+PATCHES=(
+ # fix compile failure with linux-headers-2.6.26, bug 235599
+ "${FILESDIR}"/${PN}-0.99-ifmask.patch
+ # Patch for bugs #236888 and #456648
+ "${FILESDIR}"/${P}-makefile.patch
+ # Wider arch compatibility, bug #579682
+ "${FILESDIR}"/${P}-x86emu.patch
+)
+
+src_configure() {
+ tc-export AR CC
+ append-cflags -fno-delete-null-pointer-checks #523276
+}
+
+src_compile() {
+ emake $(usev !x86 BACKEND=x86emu) LIBRARY=shared shared
+}
+
+src_install() {
+ emake \
+ LIBDIR=/usr/$(get_libdir) \
+ DESTDIR="${ED}" \
+ install-header install-shared
+}