summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-02-10 00:05:10 +0100
committerDavid Seifert <soap@gentoo.org>2020-02-10 00:05:10 +0100
commitd332eb47396f2afcd46f59a3aeec3c962f860552 (patch)
treeb27c123c06a726bbd44c3af53cbb49fd9efec8fe /dev-libs/libx86emu/libx86emu-1.1.ebuild
parentrpm.eclass: Fix for EAPI 7 (diff)
downloadgentoo-d332eb47396f2afcd46f59a3aeec3c962f860552.tar.gz
gentoo-d332eb47396f2afcd46f59a3aeec3c962f860552.tar.bz2
gentoo-d332eb47396f2afcd46f59a3aeec3c962f860552.zip
dev-libs/libx86emu: Port to EAPI 7
Closes: https://bugs.gentoo.org/684466 Closes: https://bugs.gentoo.org/706558 Package-Manager: Portage-2.3.88, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-libs/libx86emu/libx86emu-1.1.ebuild')
-rw-r--r--dev-libs/libx86emu/libx86emu-1.1.ebuild28
1 files changed, 9 insertions, 19 deletions
diff --git a/dev-libs/libx86emu/libx86emu-1.1.ebuild b/dev-libs/libx86emu/libx86emu-1.1.ebuild
index b8392b9291f2..21c131149a92 100644
--- a/dev-libs/libx86emu/libx86emu-1.1.ebuild
+++ b/dev-libs/libx86emu/libx86emu-1.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit multilib rpm toolchain-funcs
+inherit rpm toolchain-funcs
DESCRIPTION="A library for emulating x86"
HOMEPAGE="https://www.opensuse.org/"
@@ -12,24 +12,14 @@ SRC_URI="https://download.opensuse.org/source/factory/repo/oss/suse/src/${P}-9.8
LICENSE="HPND"
SLOT="0"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE=""
-src_prepare() {
- sed -i \
- -e 's:$(CC) -shared:& $(LDFLAGS):' \
- Makefile || die
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} -fPIC -Wall"
-}
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1-fix-makefile.patch
+ "${FILESDIR}"/${PN}-1.1-gcc10-fno-common.patch
+)
-src_test() {
- ln -sf libx86emu.so.1.1 libx86emu.so || die
- ln -sf libx86emu.so.1.1 libx86emu.so.1 || die
- emake \
- CC="$(tc-getCC)" \
- CFLAGS="${CFLAGS} ${LDFLAGS} -Wl,-rpath,${S} -fPIC -Wall -I../include/ -L../" test
+src_configure() {
+ tc-export CC
}
src_install() {