summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/lockdev/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/lockdev/files')
-rw-r--r--dev-libs/lockdev/files/lockdev-1.0.3-add-autotools.patch55
-rw-r--r--dev-libs/lockdev/files/lockdev-1.0.3-fix-perl.patch11
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-libs/lockdev/files/lockdev-1.0.3-add-autotools.patch b/dev-libs/lockdev/files/lockdev-1.0.3-add-autotools.patch
new file mode 100644
index 000000000000..f54bcb8fd72c
--- /dev/null
+++ b/dev-libs/lockdev/files/lockdev-1.0.3-add-autotools.patch
@@ -0,0 +1,55 @@
+Adds an autotools build system to fix the many issues with the custom build
+system (ignoring CC, CFLAGS, DESTDIR, not installing the .so file properly).
+
+Contributed by Nick Fortino (nfortino@gmail.com) 2/1/2009
+
+Updated by Jonathan Callen <abcd@gentoo.org> 2009-09-11
+
+--- Makefile.am
++++ Makefile.am
+@@ -0,0 +1,20 @@
++include_HEADERS = src/lockdev.h src/ttylock.h
++
++lib_LTLIBRARIES = liblockdev.la
++liblockdev_la_SOURCES = src/lockdev.c
++liblockdev_version = -version-info $(LOCKDEV_CURRENT_INTERFACE):$(LOCKDEV_INTERFACE_AGE):$(LOCKDEV_BINARY_AGE)
++liblockdev_la_LDFLAGS = $(liblockdev_version)
++
++man_MANS = docs/lockdev.3
++
++manpage_links = \
++ dev_lock.3 \
++ dev_unlock.3 \
++ dev_relock.3 \
++ dev_testlock.3 \
++ liblockdev.3
++
++install-data-hook:
++ for page in $(manpage_links); do \
++ $(LN_S) -f lockdev.3 $(DESTDIR)$(man3dir)/$${page} ; \
++ done
+--- configure.ac
++++ configure.ac
+@@ -0,0 +1,22 @@
++AC_INIT([lockdev], [1.0.3], [BUG-REPORT-ADDRESS])
++AC_CONFIG_AUX_DIR([scripts])
++AM_INIT_AUTOMAKE
++
++LOCKDEV_CURRENT_INTERFACE=1
++LOCKDEV_INTERFACE_AGE=0
++LOCKDEV_BINARY_AGE=0
++
++AC_SUBST([LOCKDEV_CURRENT_INTERFACE])
++AC_SUBST([LOCKDEV_INTERFACE_AGE])
++AC_SUBST([LOCKDEV_BINARY_AGE])
++
++LT_INIT([disable-static])
++
++AC_CANONICAL_BUILD
++AC_CANONICAL_HOST
++
++# Checks for programs.
++AC_PROG_LN_S
++
++AC_CONFIG_FILES([Makefile])
++AC_OUTPUT
diff --git a/dev-libs/lockdev/files/lockdev-1.0.3-fix-perl.patch b/dev-libs/lockdev/files/lockdev-1.0.3-fix-perl.patch
new file mode 100644
index 000000000000..7b25f82e7e48
--- /dev/null
+++ b/dev-libs/lockdev/files/lockdev-1.0.3-fix-perl.patch
@@ -0,0 +1,11 @@
+--- lockdev-1.0.3.orig/LockDev/Makefile.PL
++++ lockdev-1.0.3/LockDev/Makefile.PL
+@@ -7,7 +7,7 @@ WriteMakefile(
+ 'LIBS' => [''],
+ 'DEFINE' => '',
+ 'INC' => '-I../src',
+- 'MYEXTLIB' => '../src/lockdev.z',
++ 'MYEXTLIB' => '../.libs/liblockdev.so',
+ );
+
+ sub MY::postamble {