summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2024-04-18 21:28:26 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-04-18 21:28:26 +0200
commitbe8b2e9b87c96d9b926ee146c7c3e70c2de34968 (patch)
tree12a4d60ce9e4f33d540734464c24c770622ab395 /dev-libs/mxml
parentx11-apps/mesa-progs: Drop some unnecessary utility code (diff)
downloadgentoo-be8b2e9b87c96d9b926ee146c7c3e70c2de34968.tar.gz
gentoo-be8b2e9b87c96d9b926ee146c7c3e70c2de34968.tar.bz2
gentoo-be8b2e9b87c96d9b926ee146c7c3e70c2de34968.zip
dev-libs/mxml: add 4.0.2
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-libs/mxml')
-rw-r--r--dev-libs/mxml/Manifest1
-rw-r--r--dev-libs/mxml/files/mxml-4.0.2-rename-man-page.patch20
-rw-r--r--dev-libs/mxml/mxml-4.0.2.ebuild63
3 files changed, 84 insertions, 0 deletions
diff --git a/dev-libs/mxml/Manifest b/dev-libs/mxml/Manifest
index 905f517aa128..bd86a98baf5f 100644
--- a/dev-libs/mxml/Manifest
+++ b/dev-libs/mxml/Manifest
@@ -1 +1,2 @@
DIST mxml-3.3.1.tar.gz 1554784 BLAKE2B e0d599fd947dfef72edae40c1e70ea76c92105128dd46e772a7c71f9293cab3339c980396dffe105246cad64d0474935cc1939005ad9a2bffc8e8107f025a466 SHA512 43e6a92806d9c3f5db39fbf960c15ebfa6d92ef98274b7ce39b57724d6c26ad4362d6d8f3c1023efda92e6a815df068e5038a0cd479562b6be9dbdda8e827a41
+DIST mxml-4.0.2.tar.gz 1576722 BLAKE2B b5016adaf88801ec31852231ef31389d7d1d43b214d6b99e4e2b6bbfa47ba3c68fa9ac6b2ea332a61bf71688684c81e6863f1da38e30d4509cfa20f4ae943d19 SHA512 41fbd71bd390e63f0d44d006a3bcbdf95b7d3a09ea69a90d3dc86717d6f7edcd93875e6343b6d9f56ce8b2c3d34fdd4bcbb9992fb81c3392fb3deb5e3beb9482
diff --git a/dev-libs/mxml/files/mxml-4.0.2-rename-man-page.patch b/dev-libs/mxml/files/mxml-4.0.2-rename-man-page.patch
new file mode 100644
index 000000000000..a37a8fd56a90
--- /dev/null
+++ b/dev-libs/mxml/files/mxml-4.0.2-rename-man-page.patch
@@ -0,0 +1,20 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -219,7 +219,7 @@
+ $(INSTALL_DATA) mxml4.pc $(BUILDROOT)$(libdir)/pkgconfig/$(MXML_PC)
+ echo Installing man pages in $(BUILDROOT)$(mandir)...
+ $(INSTALL_DIR) $(BUILDROOT)$(mandir)/man3
+- $(INSTALL_MAN) doc/mxml.3 $(BUILDROOT)$(mandir)/man3/mxml.3
++ $(INSTALL_MAN) doc/mxml.3 $(BUILDROOT)$(mandir)/man3/mxml4.3
+
+ install-libmxml.a: libmxml.a
+ echo Installing libmxml.a to $(BUILDROOT)$(libdir)...
+@@ -276,7 +276,7 @@
+ echo Uninstalling pkgconfig files from $(BUILDROOT)$(libdir)/pkgconfig...
+ $(RM) $(BUILDROOT)$(libdir)/pkgconfig/mxml.pc
+ echo Uninstalling man pages from $(BUILDROOT)$(mandir)...
+- $(RM) $(BUILDROOT)$(mandir)/man3/mxml.3
++ $(RM) $(BUILDROOT)$(mandir)/man3/mxml4.3
+
+ uninstall-libmxml.a:
+ echo Uninstalling libmxml.a from $(BUILDROOT)$(libdir)...
diff --git a/dev-libs/mxml/mxml-4.0.2.ebuild b/dev-libs/mxml/mxml-4.0.2.ebuild
new file mode 100644
index 000000000000..4725865ea65f
--- /dev/null
+++ b/dev-libs/mxml/mxml-4.0.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="A small XML parsing library that you can use to read XML data files or strings"
+HOMEPAGE="
+ https://github.com/michaelrsweet/mxml
+ https://www.msweet.org/mxml/
+"
+SRC_URI="https://github.com/michaelrsweet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Mini-XML"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="static-libs test threads"
+RESTRICT="!test? ( test )"
+
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}/${PN}-4.0.2-rename-man-page.patch" )
+
+src_prepare() {
+ default
+
+ # Don't hardcode FORTIFY_SOURCE
+ sed -e 's/-D_FORTIFY_SOURCE=3//g' -i configure || die
+ sed -e 's/-D_FORTIFY_SOURCE=3//g' -i configure.ac || die
+
+ # Don't run always tests
+ # Enable verbose compiling
+ sed -e '/ALLTARGETS/s/testmxml//g' -e '/.SILENT:/d' -i Makefile.in || die
+ eautoconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ AR="$(tc-getAR)"
+ $(use_enable static-libs static)
+ $(use_enable threads)
+ --with-docdir=/usr/share/doc/"${PF}"
+ --with-dsoflags="${LDFLAGS}"
+ --with-ldflags="${LDFLAGS}"
+
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ default
+ use test && emake testmxml
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ emake DSTROOT="${ED}" install
+}