summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-12-10 16:02:28 +0100
committerThomas Deutschmann <whissi@gentoo.org>2018-12-10 17:44:58 +0100
commit409d5cfa9f3c792f6f0519de56411cf6092e2419 (patch)
treec2976f75aad3af977db3c53661370f56f3a7c952 /dev-libs/nanomsg/nanomsg-1.1.5.ebuild
parentapp-admin/lsyncd: bump to v2.2.3 (diff)
downloadgentoo-409d5cfa9f3c792f6f0519de56411cf6092e2419.tar.gz
gentoo-409d5cfa9f3c792f6f0519de56411cf6092e2419.tar.bz2
gentoo-409d5cfa9f3c792f6f0519de56411cf6092e2419.zip
dev-libs/nanomsg: bump to v1.1.5
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-libs/nanomsg/nanomsg-1.1.5.ebuild')
-rw-r--r--dev-libs/nanomsg/nanomsg-1.1.5.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/nanomsg/nanomsg-1.1.5.ebuild b/dev-libs/nanomsg/nanomsg-1.1.5.ebuild
new file mode 100644
index 000000000000..73f7851f7dd1
--- /dev/null
+++ b/dev-libs/nanomsg/nanomsg-1.1.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-multilib
+
+DESCRIPTION="High-performance messaging interface for distributed applications"
+HOMEPAGE="https://nanomsg.org/"
+SRC_URI="https://github.com/nanomsg/nanomsg/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/5.0.0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="doc static-libs"
+
+DEPEND="doc? ( dev-ruby/asciidoctor )"
+RDEPEND=""
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DNN_STATIC_LIB=$(usex static-libs ON OFF)
+ )
+ if multilib_is_native_abi; then
+ mycmakeargs+=(
+ -DNN_ENABLE_DOC=$(usex doc ON OFF)
+ )
+ else
+ mycmakeargs+=(
+ -DNN_ENABLE_DOC=OFF
+ -DNN_ENABLE_TOOLS=OFF
+ -DNN_ENABLE-NANOCAT=OFF
+ )
+ fi
+ cmake-utils_src_configure
+}