summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/openobex
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/openobex')
-rw-r--r--dev-libs/openobex/Manifest2
-rw-r--r--dev-libs/openobex/files/openobex-1.5-use-flags.patch224
-rw-r--r--dev-libs/openobex/metadata.xml15
-rw-r--r--dev-libs/openobex/openobex-1.5.ebuild43
-rw-r--r--dev-libs/openobex/openobex-1.7.1.ebuild45
5 files changed, 329 insertions, 0 deletions
diff --git a/dev-libs/openobex/Manifest b/dev-libs/openobex/Manifest
new file mode 100644
index 000000000000..e011096075a3
--- /dev/null
+++ b/dev-libs/openobex/Manifest
@@ -0,0 +1,2 @@
+DIST openobex-1.5.tar.gz 400876 SHA256 e602047570799a47ecb028420bda8f2cef41310e5a99d084de10aa9422935e65 SHA512 a9b8a49a1146c4aa69eb2e1ccc56a2c7ad7e70762c51f66f2009c6711699dd16ffe2efd47ac372f5a4ce947e3ef8ffd646206d75e55899294b43c062e23faa25 WHIRLPOOL ea0453f54ae1e81504ea3308de1b2a169b11f148678b769357b723209f545090d04610dd2fcc4f22b48b2c207f4bcbd1475636694d2d2d310fc3ca9300a58c7b
+DIST openobex-1.7.1-Source.tar.gz 131091 SHA256 3b264665d90901ea4ff720332ffb9b6d1d8f67187463d3a3279caddc7205ea57 SHA512 df38b363bd4c6eb6c0181fc7858fb03ac2bdfa85d8496faaa514d5cc4473b33c883956d4e1c94c3fefa5e44e5eed35a8dfcab889ce6ca8c29694f2b18334754e WHIRLPOOL 26728f0bd9186d69bff408372db40f62dc1230772ebaea70892e91095d043526adf71d97b6fe2c9736256214cc969ead91df9f1c22247a6a137e9ec950ada57d
diff --git a/dev-libs/openobex/files/openobex-1.5-use-flags.patch b/dev-libs/openobex/files/openobex-1.5-use-flags.patch
new file mode 100644
index 000000000000..c2907752e839
--- /dev/null
+++ b/dev-libs/openobex/files/openobex-1.5-use-flags.patch
@@ -0,0 +1,224 @@
+diff -Nru openobex-1.5.orig/acinclude.m4 openobex-1.5/acinclude.m4
+--- openobex-1.5.orig/acinclude.m4 2009-09-20 12:13:44.000000000 +0200
++++ openobex-1.5/acinclude.m4 2009-09-20 12:18:38.000000000 +0200
+@@ -42,6 +42,52 @@
+ fi
+
+ AC_DEFINE_UNQUOTED(CONFIGDIR, "${configdir}", [Directory for the configuration files])
++
++ fortify_enable=yes
++ irda_enable=yes
++ bluetooth_enable=yes
++ usb_enable=yes
++ glib_enable=no
++ apps_enable=no
++ debug_enable=no
++ syslog_enable=no
++ dump_enable=no
++
++ AC_ARG_ENABLE(fortify, AC_HELP_STRING([--disable-fortify], [disable compile time buffer checks]), [
++ fortify_enable=${enableval}
++ ])
++
++ AC_ARG_ENABLE(irda, AC_HELP_STRING([--disable-irda], [disable IrDA support]), [
++ irda_enable=${enableval}
++ ])
++
++ AC_ARG_ENABLE(bluetooth, AC_HELP_STRING([--disable-bluetooth], [disable Bluetooth support]), [
++ bluetooth_enable=${enableval}
++ ])
++
++ AC_ARG_ENABLE(usb, AC_HELP_STRING([--disable-usb], [disable USB support]), [
++ usb_enable=${enableval}
++ ])
++
++ dnl AC_ARG_ENABLE(glib, AC_HELP_STRING([--enable-glib], [enable GLib bindings]), [
++ dnl glib_enable=${enableval}
++ dnl ])
++
++ AC_ARG_ENABLE(apps, AC_HELP_STRING([--enable-apps], [enable test applications]), [
++ apps_enable=${enableval}
++ ])
++
++ AC_ARG_ENABLE(debug, AC_HELP_STRING([--enable-debug], [enable compiling with debugging information]), [
++ debug_enable=${enableval}
++ ])
++
++ AC_ARG_ENABLE(syslog, AC_HELP_STRING([--enable-syslog], [enable debugging to the system logger]), [
++ syslog_enable=${enableval}
++ ])
++
++ AC_ARG_ENABLE(dump, AC_HELP_STRING([--enable-dump], [enable protocol dumping for debugging]), [
++ dump_enable=${enableval}
++ ])
+ ])
+
+ AC_DEFUN([AC_PATH_WIN32], [
+@@ -78,19 +124,21 @@
+ ])
+
+ AC_DEFUN([AC_PATH_IRDA], [
+- case $host in
+- *-*-linux*)
+- AC_PATH_IRDA_LINUX
+- ;;
+- *-*-mingw32*)
+- AC_PATH_IRDA_WIN32
+- ;;
+- *)
+- irda_found=no;
+- AC_MSG_CHECKING([for IrDA support])
+- AC_MSG_RESULT([$irda_found])
+- ;;
+- esac
++ if (test "$irda_enable" = 'yes'); then
++ case $host in
++ *-*-linux*)
++ AC_PATH_IRDA_LINUX
++ ;;
++ *-*-mingw32*)
++ AC_PATH_IRDA_WIN32
++ ;;
++ *)
++ irda_found=no;
++ AC_MSG_CHECKING([for IrDA support])
++ AC_MSG_RESULT([$irda_found])
++ ;;
++ esac
++ fi
+ ])
+
+ AC_DEFUN([AC_PATH_WINBT], [
+@@ -130,45 +178,48 @@
+ ])
+
+ AC_DEFUN([AC_PATH_BLUETOOTH], [
+- case $host in
+- *-*-linux*)
+- AC_PATH_BLUEZ
+- ;;
+- *-*-freebsd*)
+- AC_PATH_FREEBSDBT
+- ;;
+- *-*-netbsd*)
+- AC_PATH_NETBSDBT
+- ;;
+- *-*-mingw32*)
+- AC_PATH_WINBT
+- ;;
+- esac
++ if (test "$bluetooth_enable" = 'yes'); then
++ case $host in
++ *-*-linux*)
++ AC_PATH_BLUEZ
++ ;;
++ *-*-freebsd*)
++ AC_PATH_FREEBSDBT
++ ;;
++ *-*-netbsd*)
++ AC_PATH_NETBSDBT
++ ;;
++ *-*-mingw32*)
++ AC_PATH_WINBT
++ ;;
++ esac
++ fi
+ AC_SUBST(BLUETOOTH_CFLAGS)
+ AC_SUBST(BLUETOOTH_LIBS)
+ ])
+
+ AC_DEFUN([AC_PATH_USB], [
+ usb_lib_found=no
+- case $host in
+- *-*-mingw32*)
+- USB_CFLAGS=""
+- USB_LIBS="-lusb"
+- usb_lib_found=yes
+- ;;
+- *)
+- PKG_CHECK_MODULES(USB, libusb, usb_lib_found=yes, AC_MSG_RESULT(no))
+- AC_CHECK_FILE(${prefix}/lib/pkgconfig/libusb.pc, REQUIRES="libusb")
+- ;;
+- esac
+- AC_SUBST(USB_CFLAGS)
+- AC_SUBST(USB_LIBS)
+-
+ usb_get_busses=no
+- AC_CHECK_LIB(usb, usb_get_busses, usb_get_busses=yes, AC_DEFINE(NEED_USB_GET_BUSSES, 1, [Define to 1 if you need the usb_get_busses() function.]))
+-
+ usb_interrupt_read=no
+- AC_CHECK_LIB(usb, usb_interrupt_read, usb_interrupt_read=yes, AC_DEFINE(NEED_USB_INTERRUPT_READ, 1, [Define to 1 if you need the usb_interrupt_read() function.]))
++ if (test "$usb_enable" = 'yes'); then
++ case $host in
++ *-*-mingw32*)
++ USB_CFLAGS=""
++ USB_LIBS="-lusb"
++ usb_lib_found=yes
++ ;;
++ *)
++ PKG_CHECK_MODULES(USB, libusb, usb_lib_found=yes, AC_MSG_RESULT(no))
++ AC_CHECK_FILE(${prefix}/lib/pkgconfig/libusb.pc, REQUIRES="libusb")
++ ;;
++ esac
++
++ AC_CHECK_LIB(usb, usb_get_busses, usb_get_busses=yes, AC_DEFINE(NEED_USB_GET_BUSSES, 1, [Define to 1 if you need the usb_get_busses() function.]))
++ AC_CHECK_LIB(usb, usb_interrupt_read, usb_interrupt_read=yes, AC_DEFINE(NEED_USB_INTERRUPT_READ, 1, [Define to 1 if you need the usb_interrupt_read() function.]))
++ fi
++ AC_SUBST(USB_CFLAGS)
++ AC_SUBST(USB_LIBS)
+
+ if (test "$usb_lib_found" = "yes" && test "$usb_get_busses" = "yes" && test "$usb_interrupt_read" = "yes"); then
+ usb_found=yes
+@@ -201,52 +252,6 @@
+ ])
+
+ AC_DEFUN([AC_ARG_OPENOBEX], [
+- fortify_enable=yes
+- irda_enable=yes
+- bluetooth_enable=yes
+- usb_enable=yes
+- glib_enable=no
+- apps_enable=no
+- debug_enable=no
+- syslog_enable=no
+- dump_enable=no
+-
+- AC_ARG_ENABLE(fortify, AC_HELP_STRING([--disable-fortify], [disable compile time buffer checks]), [
+- fortify_enable=${enableval}
+- ])
+-
+- AC_ARG_ENABLE(irda, AC_HELP_STRING([--disable-irda], [disable IrDA support]), [
+- irda_enable=${enableval}
+- ])
+-
+- AC_ARG_ENABLE(bluetooth, AC_HELP_STRING([--disable-bluetooth], [disable Bluetooth support]), [
+- bluetooth_enable=${enableval}
+- ])
+-
+- AC_ARG_ENABLE(usb, AC_HELP_STRING([--disable-usb], [disable USB support]), [
+- usb_enable=${enableval}
+- ])
+-
+- dnl AC_ARG_ENABLE(glib, AC_HELP_STRING([--enable-glib], [enable GLib bindings]), [
+- dnl glib_enable=${enableval}
+- dnl ])
+-
+- AC_ARG_ENABLE(apps, AC_HELP_STRING([--enable-apps], [enable test applications]), [
+- apps_enable=${enableval}
+- ])
+-
+- AC_ARG_ENABLE(debug, AC_HELP_STRING([--enable-debug], [enable compiling with debugging information]), [
+- debug_enable=${enableval}
+- ])
+-
+- AC_ARG_ENABLE(syslog, AC_HELP_STRING([--enable-syslog], [enable debugging to the system logger]), [
+- syslog_enable=${enableval}
+- ])
+-
+- AC_ARG_ENABLE(dump, AC_HELP_STRING([--enable-dump], [enable protocol dumping for debugging]), [
+- dump_enable=${enableval}
+- ])
+-
+ if (test "${fortify_enable}" = "yes"); then
+ CFLAGS="$CFLAGS -D_FORTIFY_SOURCE=2"
+ fi
diff --git a/dev-libs/openobex/metadata.xml b/dev-libs/openobex/metadata.xml
new file mode 100644
index 000000000000..63e47fd2c4e3
--- /dev/null
+++ b/dev-libs/openobex/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>Free open source implementation of the Object Exchange (OBEX) protocol,
+used for transferring data to/from mobile devices.</longdescription>
+ <use>
+ <flag name="irda">Enable IrDA support</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">openobex</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-libs/openobex/openobex-1.5.ebuild b/dev-libs/openobex/openobex-1.5.ebuild
new file mode 100644
index 000000000000..4348c8dcad52
--- /dev/null
+++ b/dev-libs/openobex/openobex-1.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils autotools
+
+DESCRIPTION="An implementation of the OBEX protocol used for transferring data to mobile devices"
+HOMEPAGE="http://sourceforge.net/projects/openobex/"
+SRC_URI="mirror://kernel/linux/bluetooth/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 arm hppa ppc ppc64 sparc x86"
+IUSE="bluetooth debug irda syslog usb"
+
+RDEPEND="bluetooth? ( net-wireless/bluez )
+ usb? ( virtual/libusb:0 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-use-flags.patch
+ sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-apps \
+ $(use_enable irda) \
+ $(use_enable bluetooth) \
+ $(use_enable usb) \
+ $(use_enable debug) \
+ $(use_enable debug dump) \
+ $(use_enable syslog)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc README AUTHORS NEWS ChangeLog
+}
diff --git a/dev-libs/openobex/openobex-1.7.1.ebuild b/dev-libs/openobex/openobex-1.7.1.ebuild
new file mode 100644
index 000000000000..1a1d05d30960
--- /dev/null
+++ b/dev-libs/openobex/openobex-1.7.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils udev
+
+DESCRIPTION="An implementation of the OBEX protocol used for transferring data to mobile devices"
+HOMEPAGE="http://sourceforge.net/projects/openobex/"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}-Source.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0/2"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="bluetooth irda usb"
+
+RDEPEND="bluetooth? ( net-wireless/bluez:= )
+ usb? ( virtual/libusb:= )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${P}-Source
+
+src_prepare() {
+ # Some of the bundled macros require C++... so making the project
+ # C only makes it impossible to build. CMake is awesome, isn't it?
+ sed -i -e '/project/s:C::' CMakeLists.txt || die
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DOPENOBEX_BLUETOOTH=$(usex bluetooth)
+ -DOPENOBEX_IRDA=$(usex irda)
+ -DOPENOBEX_USB=$(usex usb)
+ # TODO: enable them. patch would be appreciated.
+ -DBUILD_DOCUMENTATION=OFF
+
+ -DCMAKE_INSTALL_UDEVRULESDIR="$(get_udevdir)/rules.d"
+ )
+
+ cmake-utils_src_configure
+}