summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2016-06-11 18:53:35 +0300
committerAlon Bar-Lev <alonbl@gentoo.org>2016-06-11 18:53:52 +0300
commit45ac7985b20ac36d80090105d9b34885432e5ad5 (patch)
treeec2eccd975856c011289ab18d9ba558d82c33fdb /dev-libs/opensc/opensc-0.16.0.ebuild
parentwww-servers/nginx: Security cleanup (diff)
downloadgentoo-45ac7985b20ac36d80090105d9b34885432e5ad5.tar.gz
gentoo-45ac7985b20ac36d80090105d9b34885432e5ad5.tar.bz2
gentoo-45ac7985b20ac36d80090105d9b34885432e5ad5.zip
dev-libs/opensc: version bump
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-libs/opensc/opensc-0.16.0.ebuild')
-rw-r--r--dev-libs/opensc/opensc-0.16.0.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-libs/opensc/opensc-0.16.0.ebuild b/dev-libs/opensc/opensc-0.16.0.ebuild
new file mode 100644
index 000000000000..4d50416cad33
--- /dev/null
+++ b/dev-libs/opensc/opensc-0.16.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Libraries and applications to access smartcards"
+HOMEPAGE="https://github.com/OpenSC/OpenSC/wiki"
+SRC_URI="https://github.com/OpenSC/OpenSC/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc +pcsc-lite secure-messaging openct ctapi readline ssl zlib"
+
+RDEPEND="zlib? ( sys-libs/zlib )
+ readline? ( sys-libs/readline:0= )
+ ssl? ( dev-libs/openssl:0= )
+ openct? ( >=dev-libs/openct-0.5.0 )
+ pcsc-lite? ( >=sys-apps/pcsc-lite-1.3.0 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt"
+
+REQUIRED_USE="
+ pcsc-lite? ( !openct !ctapi )
+ openct? ( !pcsc-lite !ctapi )
+ ctapi? ( !pcsc-lite !openct )
+ || ( pcsc-lite openct ctapi )"
+
+src_configure() {
+ econf \
+ --docdir="/usr/share/doc/${PF}" \
+ --htmldir='$(docdir)/html' \
+ --disable-static \
+ $(use_enable doc) \
+ $(use_enable openct) \
+ $(use_enable readline) \
+ $(use_enable zlib) \
+ $(use_enable secure-messaging sm) \
+ $(use_enable ssl openssl) \
+ $(use_enable pcsc-lite pcsc) \
+ $(use_enable openct) \
+ $(use_enable ctapi)
+}
+
+src_install() {
+ default
+ find "${ED}"/usr -name '*.la' -delete
+}