summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSv. Lockal <lockalsash@gmail.com>2024-01-09 13:55:57 +0000
committerSam James <sam@gentoo.org>2024-01-20 13:02:18 +0000
commitaf35827c5fdb9e5ae44b0b16c0ff2acd68f5edab (patch)
tree7b004819e8274d2fe78c902c3f140f8de8c53ba3 /dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-5.7.1-r1.ebuild
parentdev-cpp/eigen: add 3.4.0-r2, 3.4.9999, 9999 with fixed cuda tests (diff)
downloadgentoo-af35827c5fdb9e5ae44b0b16c0ff2acd68f5edab.tar.gz
gentoo-af35827c5fdb9e5ae44b0b16c0ff2acd68f5edab.tar.bz2
gentoo-af35827c5fdb9e5ae44b0b16c0ff2acd68f5edab.zip
dev-libs/rocm-opencl-runtime: fix linker error for ld.lld: error: version script assignment issue
Upstream bug: https://github.com/RadeonOpenCompute/ROCm-OpenCL-Runtime/issues/155 Signed-off-by: Sv. Lockal <lockalsash@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/34720 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-5.7.1-r1.ebuild')
-rw-r--r--dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-5.7.1-r1.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-5.7.1-r1.ebuild b/dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-5.7.1-r1.ebuild
index 00c9aabadb7c..ae568be79b96 100644
--- a/dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-5.7.1-r1.ebuild
+++ b/dev-libs/rocm-opencl-runtime/rocm-opencl-runtime-5.7.1-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
ROCM_SKIP_GLOBALS=1
-inherit cmake edo flag-o-matic rocm
+inherit cmake edo flag-o-matic toolchain-funcs rocm
DESCRIPTION="Radeon Open Compute OpenCL Compatible Runtime"
HOMEPAGE="https://github.com/ROCm-Developer-Tools/clr"
@@ -48,6 +48,14 @@ OB git-r3_checkout
}
src_configure() {
+ # Fix ld.lld linker error: https://github.com/RadeonOpenCompute/ROCm-OpenCL-Runtime/issues/155
+ # ideally we want !tc-ld-is-bfd for best future-proofing, but it needs
+ # https://github.com/gentoo/gentoo/pull/28355
+ # mold needs this too but right now tc-ld-is-mold is also not available
+ if tc-ld-is-lld; then
+ append-ldflags -Wl,--undefined-version
+ fi
+
# Reported upstream: https://github.com/RadeonOpenCompute/ROCm-OpenCL-Runtime/issues/120
append-cflags -fcommon