summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 19:11:32 +0100
committerSam James <sam@gentoo.org>2021-04-19 20:12:08 +0100
commit17ebc18d38c78aa29c8d65cdf181afd812fb04ac (patch)
treeceb46e1b1b2b87045bb89dd1e3207ddf13bdb893 /dev-libs/ucl/ucl-1.03-r1.ebuild
parentmedia-radio/direwolf: drop 1.4 (epatch) (diff)
downloadgentoo-17ebc18d38c78aa29c8d65cdf181afd812fb04ac.tar.gz
gentoo-17ebc18d38c78aa29c8d65cdf181afd812fb04ac.tar.bz2
gentoo-17ebc18d38c78aa29c8d65cdf181afd812fb04ac.zip
dev-libs/ucl: port to EAPI 7
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/ucl/ucl-1.03-r1.ebuild')
-rw-r--r--dev-libs/ucl/ucl-1.03-r1.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/dev-libs/ucl/ucl-1.03-r1.ebuild b/dev-libs/ucl/ucl-1.03-r1.ebuild
index 38e1c6530d1c..9f03c5c83fff 100644
--- a/dev-libs/ucl/ucl-1.03-r1.ebuild
+++ b/dev-libs/ucl/ucl-1.03-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit autotools epatch flag-o-matic ltprune
+inherit autotools flag-o-matic
DESCRIPTION="the UCL Compression Library"
HOMEPAGE="http://www.oberhumer.com/opensource/ucl/"
@@ -16,9 +16,13 @@ IUSE="static-libs"
DEPEND="!!dev-libs/libucl"
+PATCHES=(
+ "${FILESDIR}"/${P}-CFLAGS.patch
+ "${FILESDIR}"/${P}-x32.patch #426334
+)
+
src_prepare() {
- epatch "${FILESDIR}"/${P}-CFLAGS.patch
- epatch "${FILESDIR}"/${P}-x32.patch #426334
+ default
# lzo (and ucl) have some weird sort of mfx_* set of autoconf macros
# which may only be distributed with lzo itself? Rescue them and
@@ -42,5 +46,6 @@ src_configure() {
src_install() {
default
- prune_libtool_files
+
+ find "${ED}" -type f -name '*.la' -delete || die
}