summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-11-06 10:37:09 -0500
committerMatt Turner <mattst88@gentoo.org>2022-11-06 13:25:50 -0500
commit84d63be6ccca7b144552b6dcf5df592c2169882f (patch)
treee46c91afcb3ba053c66990d96e02fd02b4adb5d3 /dev-libs/wayland-protocols/wayland-protocols-1.28.ebuild
parentdev-libs/appstream-glib: Version bump to 0.8.2 (diff)
downloadgentoo-84d63be6ccca7b144552b6dcf5df592c2169882f.tar.gz
gentoo-84d63be6ccca7b144552b6dcf5df592c2169882f.tar.bz2
gentoo-84d63be6ccca7b144552b6dcf5df592c2169882f.zip
dev-libs/wayland-protocols: Version bump to 1.28
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs/wayland-protocols/wayland-protocols-1.28.ebuild')
-rw-r--r--dev-libs/wayland-protocols/wayland-protocols-1.28.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-libs/wayland-protocols/wayland-protocols-1.28.ebuild b/dev-libs/wayland-protocols/wayland-protocols-1.28.ebuild
new file mode 100644
index 000000000000..4eff41270cb0
--- /dev/null
+++ b/dev-libs/wayland-protocols/wayland-protocols-1.28.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Wayland protocol files"
+HOMEPAGE="https://wayland.freedesktop.org/"
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/wayland/${PN}.git/"
+ inherit git-r3
+else
+ SRC_URI="https://gitlab.freedesktop.org/wayland/${PN}/-/releases/${PV}/downloads/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? ( dev-libs/wayland )
+"
+RDEPEND=""
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}