summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichel Boaventura <michel.boaventura@gmail.com>2018-04-10 23:47:59 -0300
committerPatrice Clement <monsieurp@gentoo.org>2018-05-01 23:29:18 +0200
commit0eef2be5649b5615ba66761050a92edafdb31f66 (patch)
tree2a3fea4f0cc8da702861222c49d87fcaa2ee986c /dev-libs
parentapp-i18n/man-pages-ja: version bump to 20180315. (diff)
downloadgentoo-0eef2be5649b5615ba66761050a92edafdb31f66.tar.gz
gentoo-0eef2be5649b5615ba66761050a92edafdb31f66.tar.bz2
gentoo-0eef2be5649b5615ba66761050a92edafdb31f66.zip
dev-libs/json-c: version bump to 0.13.1.
Closes: https://github.com/gentoo/gentoo/pull/7935
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/json-c/Manifest1
-rw-r--r--dev-libs/json-c/json-c-0.13.1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-libs/json-c/Manifest b/dev-libs/json-c/Manifest
index e5d0725bc837..3e21cf157eaa 100644
--- a/dev-libs/json-c/Manifest
+++ b/dev-libs/json-c/Manifest
@@ -1,3 +1,4 @@
DIST json-c-0.12.1.tar.gz 535086 BLAKE2B 57e1da29b3326ccad07a60aafbe653a33b1bbbc26d184c916deb4d120b81781ad52d9945ee3cf5f44b112d41b274872ca76b94a05c12ccc003faecbed5fa586f SHA512 038676a0ce815e5174161fbd4339524feadc294d517f732fb408ad6aa7c4906423451c13386107569d9f24746a1a101564ca511e92e8276c5bf5b8c022ca42ed
DIST json-c-0.12.tar.gz 501419 BLAKE2B 24f035792ff1ba5c39e55bca6ee4ba2509ab71d0374c70b520791f38e1ec4ff2245a282f234fde9f4a02cd9eaaaaa998ce307563a20702c04ee972fdf51f2539 SHA512 c959804362386f6b77e9d04b5fedf6d6aff1fcd0ab50250edb25f759b510b402e7ad4b33d1cbadc3337b63a3145d19f310812a9ee351748348304b384dc2dc35
+DIST json-c-0.13.1.tar.gz 639425 BLAKE2B 1da310309f9ce03306a9fd4a161670e460cf0b2222348df7c006902390f74a4cf100aab1ce6ac8a361a278dd917c114a278de5b3445817f3a40ae287478add46 SHA512 e984db2a42b9c95b52c798b2e8dd1b79951a8dcba27370af30c43b9549fbb00008dbcf052a535c528209aaee38e6d1f760168b706905ae72f3e704ed20f8a1a1
DIST json-c-0.13.tar.gz 634720 BLAKE2B f83876921f94fca1eb0a3473315d4dc75bb52e36499b265dd60e9dfa46d5417a958725aa3a6da3aa50f2a64f2cd5308af2685ca18bb3f5becd464fc570313735 SHA512 7375e1678e40f79298226d070db4ac3dab8a94c9d2438db1bbbcf668284ab30236fc77d841207c25f71cc2cebc596e1b8116d480434d829c8d96007a32ddf636
diff --git a/dev-libs/json-c/json-c-0.13.1.ebuild b/dev-libs/json-c/json-c-0.13.1.ebuild
new file mode 100644
index 000000000000..9908d135cd23
--- /dev/null
+++ b/dev-libs/json-c/json-c-0.13.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools multilib-minimal ltprune
+
+DESCRIPTION="A JSON implementation in C"
+HOMEPAGE="https://github.com/json-c/json-c/wiki"
+SRC_URI="https://s3.amazonaws.com/json-c_releases/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc static-libs"
+
+src_prepare() {
+ default
+ sed -i -e "s:-Werror::" configure.ac || die
+ eautoreconf
+
+ # tests break otherwise
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} econf $(use_enable static-libs static)
+}
+
+multilib_src_test() {
+ export USE_VALGRIND=0 VERBOSE=1
+ default
+}
+
+multilib_src_install_all() {
+ use doc && HTML_DOCS=( "${S}"/doc/html/. )
+ einstalldocs
+
+ # add symlink for projects not using pkgconfig
+ dosym ../json-c /usr/include/json-c/json
+
+ prune_libtool_files
+}