summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-12-05 20:49:30 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-12-05 22:45:04 +0100
commitd6fb588acbe0bc5b3e3cccb0f389b9476b77ec9a (patch)
tree289703777b8a26b637541b01a80c86ae457cb630 /dev-libs
parentmedia-libs/gmmlib: amd64 stable (diff)
downloadgentoo-d6fb588acbe0bc5b3e3cccb0f389b9476b77ec9a.tar.gz
gentoo-d6fb588acbe0bc5b3e3cccb0f389b9476b77ec9a.tar.bz2
gentoo-d6fb588acbe0bc5b3e3cccb0f389b9476b77ec9a.zip
dev-libs/intel-compute-runtime: add 21.48.21782
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/intel-compute-runtime/Manifest1
-rw-r--r--dev-libs/intel-compute-runtime/intel-compute-runtime-21.48.21782.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-libs/intel-compute-runtime/Manifest b/dev-libs/intel-compute-runtime/Manifest
index 867445afa321..f8b0ab23725f 100644
--- a/dev-libs/intel-compute-runtime/Manifest
+++ b/dev-libs/intel-compute-runtime/Manifest
@@ -2,3 +2,4 @@ DIST intel-compute-runtime-21.44.21506.tar.gz 4851449 BLAKE2B beb49e8bbbfab098bb
DIST intel-compute-runtime-21.45.21574.tar.gz 4868091 BLAKE2B 48ff1ba42e5fe5eb231ec82bb7b33d0bb96460fc5adbfcb4702b68397d58b1b88f2a4e5a2dbef462731d43c284439cc4626ebf308d9dcfc509ccb68cea63eb19 SHA512 ede4ca4772ec6518592557d4c49d0a25204773607ae6737a35d20a3abb73ebbe66d01139baba544d5292d848a05a166a2c5ca1712408f85ce6be840bcf104650
DIST intel-compute-runtime-21.46.21636.tar.gz 4878855 BLAKE2B 0ada296b36567038b2abeba50c2dae6604981f00cdfc0d5d9d197c793534c887fa1d321ced34b37cf6760bdc9e2b8769cdc24fe3884036b78b983660c90b1ee7 SHA512 a63436d049737b955f0e23bbfc78684f665f3d1a668120e803165839792144154f3f42a52c6533611711592ba6e41408d81196a61e318746b1dae1392d1d29ac
DIST intel-compute-runtime-21.47.21710.tar.gz 4894551 BLAKE2B 446d9b89a1823f7ce83638010e5285fe8d42018347ded266fd6a091cd0815583ff3ebd0e762a4a8c9c83f6a053c6fe7fecff2a127124c584ad211d58b4932992 SHA512 ce983d09ca87daea8be75e284766aea49262f749017a485ec3b2eb8c14dbeb91b1aeea012178798aa1d90151cfd77f5ce2b44b15a84ea66b5c7573f667a5b3c8
+DIST intel-compute-runtime-21.48.21782.tar.gz 4939993 BLAKE2B 591b59523cf7d51b75b69fa0fcdd10931a22f5d236ea279ce764a240d43ca484441f9a97c06f0cf928434da364ac81613719c76a5ad75b5a21828d85c91d663b SHA512 18e6365d3292293bd904ed727d6038c25e806b50b10958fb87c2e90992e3b205d89570dcc4d9d54bdfe98d265dbfbffa930f6db68bc37f228f909e29ce7c3c91
diff --git a/dev-libs/intel-compute-runtime/intel-compute-runtime-21.48.21782.ebuild b/dev-libs/intel-compute-runtime/intel-compute-runtime-21.48.21782.ebuild
new file mode 100644
index 000000000000..93ce17f13ec3
--- /dev/null
+++ b/dev-libs/intel-compute-runtime/intel-compute-runtime-21.48.21782.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+MY_PN="${PN/intel-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Intel Graphics Compute Runtime for oneAPI Level Zero and OpenCL Driver"
+HOMEPAGE="https://github.com/intel/compute-runtime"
+SRC_URI="https://github.com/intel/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+l0 +vaapi"
+
+RDEPEND="
+ dev-libs/libnl:3
+ dev-libs/libxml2:2
+ >=dev-util/intel-graphics-compiler-1.0.9389
+ >=dev-util/intel-graphics-system-controller-0.2.4
+ >=media-libs/gmmlib-21.2.1
+ >=virtual/opencl-3
+ l0? ( >=dev-libs/level-zero-1.6.2 )
+ vaapi? (
+ x11-libs/libdrm[video_cards_intel]
+ x11-libs/libva
+ )
+"
+
+# for Khronos OpenGL headers
+DEPEND="
+ ${RDEPEND}
+ media-libs/mesa
+"
+
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( "README.md" "FAQ.md" )
+
+PATCHES=( "${FILESDIR}/${PN}-21.31.20514-no_Werror.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_WITH_L0="$(usex l0)"
+ -DDISABLE_LIBVA="$(usex !vaapi)"
+ -DKHRONOS_GL_HEADERS_DIR="${ESYSROOT}/usr/include"
+ -DOCL_ICD_VENDORDIR="${EPREFIX}/etc/OpenCL/vendors"
+
+ # If enabled, tests are automatically run during
+ # the compile phase and we cannot run them because
+ # they require permissions to access the hardware.
+ -DSKIP_UNIT_TESTS="ON"
+ )
+
+ cmake_src_configure
+}