summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2024-06-17 20:19:26 +0200
committerUlrich Müller <ulm@gentoo.org>2024-06-17 20:20:35 +0200
commitc6987e44df77244504265fdf9d35882cbef0292f (patch)
tree755f7f9f457ad9514842a313d1355a78bbd4b07b /dev-lisp
parentdev-lisp/cl-ppcre: add 2.1.2 (diff)
downloadgentoo-c6987e44df77244504265fdf9d35882cbef0292f.tar.gz
gentoo-c6987e44df77244504265fdf9d35882cbef0292f.tar.bz2
gentoo-c6987e44df77244504265fdf9d35882cbef0292f.zip
dev-lisp/cl-ppcre-unicode: add 2.1.2
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/cl-ppcre-unicode/Manifest1
-rw-r--r--dev-lisp/cl-ppcre-unicode/cl-ppcre-unicode-2.1.2.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-lisp/cl-ppcre-unicode/Manifest b/dev-lisp/cl-ppcre-unicode/Manifest
index ebac6b44582f..47eafcd5ee1a 100644
--- a/dev-lisp/cl-ppcre-unicode/Manifest
+++ b/dev-lisp/cl-ppcre-unicode/Manifest
@@ -1 +1,2 @@
DIST cl-ppcre-2.1.0.tar.gz 159051 BLAKE2B d1b9dd93c3f4c4c3a23a7c01f28cc4a8cc8543bfa3280f60b53d61dadb377f9e45c0f79592323bb7dcaf06721d899159f958f5b7d391370eeb5c6ede81a7a0cd SHA512 c9c95c58628fd5ecebf6e24e0c26913719360c325e90e78c256d1306eb8c2cbe85a2a5f617fdb6c2a7091bd80f4021ad0d294371b2696ad8e5873eca13aab866
+DIST cl-ppcre-2.1.2.tar.gz 159376 BLAKE2B 73ca66402066401e52bc685bf2cd1a66a15b7688e3415ffa1eac2de28bbc577808752122bcb56967c061a83a547046bd3c2667fbaa5dc37d135b6cf67f29e10b SHA512 bfcea40b251a21861dae4883f6d5b277626ae2bed86fb895173e011bdf35a289eee949a3a87b3e83ed123ae22f2a19268038e624b378fd98d28855dda9e11f78
diff --git a/dev-lisp/cl-ppcre-unicode/cl-ppcre-unicode-2.1.2.ebuild b/dev-lisp/cl-ppcre-unicode/cl-ppcre-unicode-2.1.2.ebuild
new file mode 100644
index 000000000000..9c950abde1a9
--- /dev/null
+++ b/dev-lisp/cl-ppcre-unicode/cl-ppcre-unicode-2.1.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit common-lisp-3
+
+DESCRIPTION="CL-PPCRE is a portable regular expression library for Common Lisp"
+HOMEPAGE="https://edicl.github.io/cl-ppcre/
+ https://www.cliki.net/cl-ppcre"
+
+SRC_URI="https://github.com/edicl/cl-ppcre/archive/v${PV}.tar.gz -> cl-ppcre-${PV}.tar.gz"
+S="${WORKDIR}/cl-ppcre-${PV}"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="~dev-lisp/cl-ppcre-${PV}
+ dev-lisp/cl-unicode"
+
+src_install() {
+ common-lisp-install-sources ${PN}/ test/unicode*
+ common-lisp-install-asdf ${PN}
+}