summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2024-06-17 23:39:08 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-06-18 00:29:35 +0200
commit80d342e43ec39ff9503aff1947592bf0275098ae (patch)
treee48fcfbcf831120c6af8dcecf933b97b4319772a /dev-lua
parentdev-lua/dkjson: add 2.8 (diff)
downloadgentoo-80d342e43ec39ff9503aff1947592bf0275098ae.tar.gz
gentoo-80d342e43ec39ff9503aff1947592bf0275098ae.tar.bz2
gentoo-80d342e43ec39ff9503aff1947592bf0275098ae.zip
dev-lua/luarocks: add 3.11.1
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/luarocks/Manifest1
-rw-r--r--dev-lua/luarocks/luarocks-3.11.1.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/dev-lua/luarocks/Manifest b/dev-lua/luarocks/Manifest
index c9a5e7d6883e..0c748f11064c 100644
--- a/dev-lua/luarocks/Manifest
+++ b/dev-lua/luarocks/Manifest
@@ -1,3 +1,4 @@
DIST luarocks-3.10.0.tar.gz 273518 BLAKE2B 64a9f7d5c9e15b8753e32f080d8f792be37f7b66635ce3df2218563774d5f90a18ef1b625861e13df9e728e1cbd90f0ed7247ce1bec207b97fa895780a77ab53 SHA512 4a834059b8f544274a110131d59d0647fb317078ef7709c1dc1a464513ebc38300abb71094620e21bb2f6e60193e9a1b0c06e7e0f4ad9acc2bf188bf4b599922
DIST luarocks-3.11.0.tar.gz 277031 BLAKE2B eadef03badc9b4f0784e67f08f4fbfb4032840e6f7378e20dd2460da6324bba9c6f0210803b42a5e7465a44f0a3cf706c555ba64f622ce3884ac0b49f42304ad SHA512 bec918e98209e5ff5c498c4454b8c8182ecfeb0786cb4cd241d59149f33560e981ff2db8d49785823ccf31643366de15b5f2599c6eef0951d17ba66436b79644
+DIST luarocks-3.11.1.tar.gz 277760 BLAKE2B 9470b0cd01329e223769b53a5aea743916c2ffedd6171a0b06e105131e2475ec4919fc1e6347162d1049ae5b2d9b32bea705e35577e58edaa29dddb910d343e7 SHA512 1e214fd41711f62fda122d73441165a2d0ffe7ed29d3d3d7690b9a1a272c03e269fc39e0c2d35dddaa64fad411b87754da4e7b8236af562fde837e9e6626fbad
DIST luarocks-3.9.2.tar.gz 256117 BLAKE2B eebbad38dd71b0318852a177d394df5fd20e807d566893a2338526e76e17daf2436309e512dd50b325914b2d84b90ef857396bfd6d41f22893131ed78931b8ad SHA512 7e93164bdcf35338e993822931a8e59957ab69c6e23236a7a075649c2f7cd173305c4ca6e9d115fc5e282cb76c21754d7adac92b21885006e5ee3bc06a9d0059
diff --git a/dev-lua/luarocks/luarocks-3.11.1.ebuild b/dev-lua/luarocks/luarocks-3.11.1.ebuild
new file mode 100644
index 000000000000..780e6d75e53f
--- /dev/null
+++ b/dev-lua/luarocks/luarocks-3.11.1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit lua-single
+
+DESCRIPTION="A package manager for the Lua programming language"
+HOMEPAGE="https://luarocks.org"
+SRC_URI="https://luarocks.org/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86"
+IUSE="test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="test"
+
+RDEPEND="${LUA_DEPS}"
+
+DEPEND="
+ net-misc/curl
+ dev-libs/openssl:0
+ ${RDEPEND}
+"
+
+BDEPEND="
+ virtual/pkgconfig
+ test? (
+ $(lua_gen_cond_dep 'dev-lua/busted[${LUA_USEDEP}]')
+ $(lua_gen_cond_dep 'dev-lua/busted-htest[${LUA_USEDEP}]')
+ ${RDEPEND}
+ )
+"
+
+src_prepare() {
+ default
+
+ # If 'dev-lang/lua' is a new, fresh installation, no 'LUA_LIBDIR' exists,
+ # as no compiled modules are installed on a new, fresh installation,
+ # so this check must be disabled, otherwise 'configure' will fail.
+ sed -e '/LUA_LIBDIR is not a valid directory/d' -i configure || die
+}
+
+src_configure() {
+ local myeconfargs=(
+ "--prefix=${EPREFIX}/usr"
+ "--rocks-tree=$(lua_get_lmod_dir)"
+ "--with-lua-include=$(lua_get_include_dir)"
+ "--with-lua-interpreter=${ELUA}"
+ "--with-lua-lib=$(lua_get_cmod_dir)"
+ )
+
+ # Since the configure script is handcrafted,
+ # and yells at unknown options, do not use 'econf'.
+ ./configure "${myeconfargs[@]}" || die
+}
+
+src_test() {
+ busted --lua=${ELUA} || die
+}
+
+src_install() {
+ default
+
+ { find "${D}" -type f -exec sed -i -e "s:${D}::g" {} \;; } || die
+}
+
+pkg_postinst() {
+ local lua_abi_ver
+ if use lua_single_target_luajit; then
+ lua_abi_ver="5.1"
+ else
+ lua_abi_ver=${ELUA#lua}
+ fi
+ elog
+ elog "To manage rocks for a Lua version other than the current ${CATEGORY}/${PN} default (${lua_abi_ver})"
+ elog "you can use the command-line option --lua-version, e.g."
+ elog
+ elog " luarocks --lua-version 5.3 install luasocket"
+ elog
+ elog "(use 5.1 for luajit). Note that the relevant Lua version must already be present in the system."
+ elog
+}