summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-27 14:43:14 +0000
committerSam James <sam@gentoo.org>2021-01-27 14:43:18 +0000
commit3f8c91ae757eaf85a02809c1ef6292e49910f05a (patch)
tree0fda3f0b5f0d7262f428cdb4bc10711c68847ef2 /dev-ml/async_rpc_kernel/async_rpc_kernel-0.14.0-r1.ebuild
parentdev-ml/protocol_version_header: update metadata (diff)
downloadgentoo-3f8c91ae757eaf85a02809c1ef6292e49910f05a.tar.gz
gentoo-3f8c91ae757eaf85a02809c1ef6292e49910f05a.tar.bz2
gentoo-3f8c91ae757eaf85a02809c1ef6292e49910f05a.zip
dev-ml/async_rpc_kernel: add dev-ml/protocol_version_header dep
Closes: https://bugs.gentoo.org/767445 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/async_rpc_kernel/async_rpc_kernel-0.14.0-r1.ebuild')
-rw-r--r--dev-ml/async_rpc_kernel/async_rpc_kernel-0.14.0-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ml/async_rpc_kernel/async_rpc_kernel-0.14.0-r1.ebuild b/dev-ml/async_rpc_kernel/async_rpc_kernel-0.14.0-r1.ebuild
new file mode 100644
index 000000000000..bbaa645aa090
--- /dev/null
+++ b/dev-ml/async_rpc_kernel/async_rpc_kernel-0.14.0-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Platform-independent core of Async RPC library"
+HOMEPAGE="https://github.com/janestreet/async_rpc_kernel"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ dev-ml/async_kernel:=
+ dev-ml/core_kernel:=
+ dev-ml/ppx_jane:=
+ dev-ml/protocol_version_header:=
+"
+DEPEND="${RDEPEND}"