summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-07-08 18:04:59 +0200
committerAlfredo Tupone <tupone@gentoo.org>2023-07-08 18:34:48 +0200
commit0de38d5350a12bb151cc63bc15f1204ab5977574 (patch)
treeebc4e78795a955aa793c93b85f86f2c52f765987 /dev-ml/async_unix
parentdev-ml/core_unix: add 0.16.0 (diff)
downloadgentoo-0de38d5350a12bb151cc63bc15f1204ab5977574.tar.gz
gentoo-0de38d5350a12bb151cc63bc15f1204ab5977574.tar.bz2
gentoo-0de38d5350a12bb151cc63bc15f1204ab5977574.zip
dev-ml/async_unix: add 0.16.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/async_unix')
-rw-r--r--dev-ml/async_unix/Manifest1
-rw-r--r--dev-ml/async_unix/async_unix-0.16.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-ml/async_unix/Manifest b/dev-ml/async_unix/Manifest
index 994715b9ceec..225fadb32619 100644
--- a/dev-ml/async_unix/Manifest
+++ b/dev-ml/async_unix/Manifest
@@ -1,2 +1,3 @@
DIST async_unix-0.14.0.tar.gz 171624 BLAKE2B 4c55b6c8ba8cd59ede4b214ec84d8689700e46b918a96e145f94ebd011c32de6c2ab40c35a4c821ac58872259740b752e045eb2ac7954ecb0b988ceaf1b75ff2 SHA512 d90713d1d35445a648392e9104eedd25d4c7e6a10a46d0442539c1521349dcbee4118e852cc8335c8c03ba4d1050f199eb91a6e3c3c827dca8eee59501f379be
DIST async_unix-0.15.0.tar.gz 178320 BLAKE2B 825efe071ecfb39ff0d5586cd8981c31a4692ee5b44727fdb22d68bfc08f9f1e296a363b87c308bef7cdd557dc9124da21bd1e772fe47dcde917b6bc5024500d SHA512 d6bb561ca06b3232c11c10bfe9dbd689020d52dc90f13f01751abf31f968649c7c8664f5f58de95c89f012de00c789efa9c0ca230ba32b9105c609d1afca2a51
+DIST async_unix-0.16.0.tar.gz 186267 BLAKE2B 1f4be6e324658d50554c7ba252de4f85c9439492ed35a3e453113c443b848bef63684b1ae752f70994b5b224e00110364442ea032a345f9f3982542e306d47e6 SHA512 9fe8f61cb3a27e9974aefa40596df744dad75aca037b0b8347c87f86f63832a993f8306c0b0e7cbf7affcedc50a53ae32bdf3be40cee04d1e41653e3697bd991
diff --git a/dev-ml/async_unix/async_unix-0.16.0.ebuild b/dev-ml/async_unix/async_unix-0.16.0.ebuild
new file mode 100644
index 000000000000..c8ec8cfad6cf
--- /dev/null
+++ b/dev-ml/async_unix/async_unix-0.16.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Jane Street Capital's asynchronous execution library (unix)"
+HOMEPAGE="https://github.com/janestreet/async_unix"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.14
+ dev-ml/async_kernel:${SLOT}
+ dev-ml/core:${SLOT}
+ dev-ml/core_kernel:${SLOT}
+ dev-ml/core_unix:${SLOT}
+ dev-ml/ppx_jane:${SLOT}
+"
+DEPEND="${RDEPEND}"