summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-22 11:46:01 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-22 11:55:45 +0100
commit0ed9bb36a72fc8d2e2967e0654c7bc59020eaf4f (patch)
tree784705bd5ead7ad93a2d4cdd9328333687f1568f /dev-ml/async_unix
parentdev-ml/async_kernel: bump to 113.33.00 (diff)
downloadgentoo-0ed9bb36a72fc8d2e2967e0654c7bc59020eaf4f.tar.gz
gentoo-0ed9bb36a72fc8d2e2967e0654c7bc59020eaf4f.tar.bz2
gentoo-0ed9bb36a72fc8d2e2967e0654c7bc59020eaf4f.zip
dev-ml/async_unix: bump to 113.33.00
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/async_unix')
-rw-r--r--dev-ml/async_unix/Manifest1
-rw-r--r--dev-ml/async_unix/async_unix-113.33.00.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-ml/async_unix/Manifest b/dev-ml/async_unix/Manifest
index e466c1d9901e..ea6bfd29ac1a 100644
--- a/dev-ml/async_unix/Manifest
+++ b/dev-ml/async_unix/Manifest
@@ -1 +1,2 @@
DIST async_unix-113.24.00.tar.gz 190626 SHA256 296492a365fc921a0d9ee42267cd72f7d0c2070a1334efbb1f6334df4de22822 SHA512 773ec9dc9240a2482f79026b1a7c0dae47ed048d8f693e87e19305635c5bb47c9f2ad41010499ce8ddd0b402af713ec860a548a7d9cdaaf9e914b7962bac4bdb WHIRLPOOL 1797d0718fe55e4e864f8cc325d54c3529c7184e0a46bc7a73bf4e6df92e3ae3b2969e4caadad25e90510ec07a04d4bcd5789cc766b22565636905b5385c43b3
+DIST async_unix-113.33.00.tar.gz 195062 SHA256 ebffb3c4341e57d4f7cb347d387b9ccbd46c46f1ebd5db0c7782cdf3237fa9ec SHA512 15ed26ba51efda3f07c1bca3e0935290ed99accaa61cb60f7460e72624944d3edb3454c2ddb29deaf9928b4d4c1332c3035cd0c8d4e2dceb3a947b0ff8ee944c WHIRLPOOL 159276f4eaccc2ba36378fc0b206ea3e4fc35a28d599786504f416fa1d70f3a42965065ac9d63e82e9e5d87481da6a6cea913953a486e790289c625f059de9ad
diff --git a/dev-ml/async_unix/async_unix-113.33.00.ebuild b/dev-ml/async_unix/async_unix-113.33.00.ebuild
new file mode 100644
index 000000000000..ab692ee59ab7
--- /dev/null
+++ b/dev-ml/async_unix/async_unix-113.33.00.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="Jane Street Capital's asynchronous execution library (unix)"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ >=dev-lang/ocaml-4.02.0:=
+ dev-ml/async_kernel:=
+ dev-ml/bin-prot:=
+ dev-ml/ocaml-ctypes:=
+ >=dev-ml/fieldslib-109.20.00:=
+ dev-ml/ppx_assert:=
+ dev-ml/ppx_bench:=
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_expect:=
+ dev-ml/ppx_inline_test:=
+ dev-ml/ppx_jane:=
+ >=dev-ml/sexplib-109.20.00:=
+ dev-ml/typerep:=
+ dev-ml/variantslib:=
+"
+DEPEND="${RDEPEND} dev-ml/opam"
+
+src_configure() {
+ emake setup.exe
+ OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+ dodoc CHANGES.md
+}