summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-08-16 16:08:36 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-08-16 16:08:48 +0200
commit970ef85669667e48dbeacaf5f9d276a9860a0bca (patch)
treeb62248967a73bf4fdf34a14205c1dceb632fb5da /dev-ml/capnp-ocaml/capnp-ocaml-2.1.1.ebuild
parentdev-ml/ocaml-uint: initial import; ebuild by me (diff)
downloadgentoo-970ef85669667e48dbeacaf5f9d276a9860a0bca.tar.gz
gentoo-970ef85669667e48dbeacaf5f9d276a9860a0bca.tar.bz2
gentoo-970ef85669667e48dbeacaf5f9d276a9860a0bca.zip
dev-ml/capnp-ocaml: initial import; ebuild by me
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ml/capnp-ocaml/capnp-ocaml-2.1.1.ebuild')
-rw-r--r--dev-ml/capnp-ocaml/capnp-ocaml-2.1.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-ml/capnp-ocaml/capnp-ocaml-2.1.1.ebuild b/dev-ml/capnp-ocaml/capnp-ocaml-2.1.1.ebuild
new file mode 100644
index 000000000000..2509cac727f9
--- /dev/null
+++ b/dev-ml/capnp-ocaml/capnp-ocaml-2.1.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="OCaml code generator plugin for the Cap'n Proto serialization framework"
+HOMEPAGE="https://github.com/pelzlpj/capnp-ocaml"
+SRC_URI="https://github.com/pelzlpj/capnp-ocaml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-lang/ocaml:=[ocamlopt]
+ dev-ml/core_kernel:=
+ dev-ml/camlp4:=
+ dev-ml/ocaml-extunix:=
+ dev-ml/ocplib-endian:=
+ dev-ml/res:=
+ dev-ml/ocaml-uint:=
+"
+DEPEND="${RDEPEND}
+ dev-util/omake
+"
+
+src_prepare() {
+ epatch "${FILESDIR}/mi.patch"
+}
+
+src_compile() {
+ PREFIX="${EPREFIX}/usr" omake --force-dotomake || die
+}
+
+src_install() {
+ findlib_src_preinst
+ DESTDIR="${D}" PREFIX="${EPREFIX}/usr" omake --force-dotomake install || die
+ dodoc README.adoc CHANGELOG.adoc
+}